uniget CLI has an EDITOR Command Injection
CVE-2026-55061GHSA-qmcq-xw74-w667
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitlab.com/uniget-org/cli 0.27.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.27.6
- Fixed in
- 0.27.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmcq-xw74-w667 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6248 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmcq-xw74-w667 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55061: 0.15% estimated exploitation activity in the next 30 days; percentile 4.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The uniget CLI has a command injection vulnerability in hooks.go line 199 where strings.Split(editor, " ") naively parses the EDITOR environment variable without respecting shell syntax. An attacker can set EDITOR="/path/to/wrapper && id && echo" which gets split into separate arguments, allowing the wrapper script to execute arbitrary commands like id. This was successfully exploited to execute uid=1000(w4nn4d13), confirming code execution is possible. The vulnerability affects hook editing and breaks configurations with modern editors like VSCode. Vulnerable Code: Location Context: Issue: Naive space-splitting allows injection. EDITOR="script && id && echo" splits into ["script", "&&", "id", "&&", "echo"] enabling command execution. Step to Reproduce Step 1: Create malicious editor wrapper Step 2: Create test hook Step 3: Set injection payload Step 4: Run vulnerable code Step 5: Observe output <img width="1017" height="449" alt="image"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-qmcq-xw74-w667
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6248
- Revision 1 · created ·
Published from osv record GHSA-qmcq-xw74-w667
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55061 Advisory: uniget CLI has an EDITOR Command Injection IDs: CVE-2026-55061, GHSA-qmcq-xw74-w667 Record: https://patchnext.com/advisories/cve-2026-55061 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gitlab.com/uniget-org/cli 0.27.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go gitlab.com/uniget-org/cli: affected < 0.27.6; fixed in 0.27.6 ## Suggested inspection (read-only) - Go gitlab.com/uniget-org/cli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gitlab.com/uniget-org/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmcq-xw74-w667 (OSV record GHSA-qmcq-xw74-w667 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6248 (OSV record GO-2026-6248 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6 (fixed)) - Verified: https://github.com/advisories/GHSA-qmcq-xw74-w667 (GitHub-reviewed advisory GHSA-qmcq-xw74-w667 lists affected ranges: Go gitlab.com/uniget-org/cli >=0 <0.27.6) Commands are suggestions: review each one before running it.
Loading voting…