Oj: Use-After-Free in Oj::Doc Iterators via Reentrant Close
CVE-2026-54897GHSA-9ppp-w3g4-fh4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oj 3.17.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems oj
- Affected
- <= 3.17.2
- Fixed in
- 3.17.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9ppp-w3g4-fh4q lists affected ranges: RubyGems oj >=0 <=3.17.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54897: 0.20% estimated exploitation activity in the next 30 days; percentile 10.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Oj::Doc iterators (eachvalue, eachchild, eachleaf) are vulnerable to a heap use-after-free. When a Ruby block yielded during iteration calls doc.close or d.close, the document's heap memory is freed while the C iterator is still running. When control returns from the block, the iterator reads from the freed region, producing a use-after-free accessible from pure Ruby. Version - Software: oj gem - Affected: all versions with ext/oj/fast.c - Latest tested: 3.17.1 (confirmed present) Details The iterators in ext/oj/fast.c follow the pattern: rbyield can invoke arbitrary Ruby code, including calling close() on the Doc or any child node, which calls rubysizedxfree on the backing buffer. On return, the C code reads cur-next from the freed region. All three iterators are affected. ASAN report (eachchild variant): All three iterators trigger the same freed region (fd shadow bytes): Reproduce
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9ppp-w3g4-fh4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54897 Advisory: Oj: Use-After-Free in Oj::Doc Iterators via Reentrant Close IDs: CVE-2026-54897, GHSA-9ppp-w3g4-fh4q Record: https://patchnext.com/advisories/cve-2026-54897 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oj 3.17.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems oj: affected <= 3.17.2; fixed in 3.17.3 ## Suggested inspection (read-only) - RubyGems oj: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oj. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9ppp-w3g4-fh4q (GitHub-reviewed advisory GHSA-9ppp-w3g4-fh4q lists affected ranges: RubyGems oj >=0 <=3.17.2) Commands are suggestions: review each one before running it.
Loading voting…