datadog-opentelemetry has unbounded W3C tracestate parsing that may lead to DoS
CVE-2026-54788GHSA-gpwf-4h98-v82q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datadog-opentelemetry 0.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io datadog-opentelemetry
- Affected
- >= 0.1.0, < 0.3.3
- Fixed in
- 0.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gpwf-4h98-v82q lists affected ranges: crates.io datadog-opentelemetry >=0.1.0 <0.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpwf-4h98-v82q lists affected ranges: crates.io datadog-opentelemetry >=0.1.0 <0.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-54788: 0.79% estimated exploitation activity in the next 30 days; percentile 56.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Datadog tracing libraries that implement W3C Trace Context (tracecontext) propagation parse the incoming tracestate header without enforcing a size cap on the Datadog vendor entry (dd=...). The dd= value contains semicolon-separated key:value pairs, and the parser allocates a hash-map entry for each pair. A remote, unauthenticated attacker can send a tracestate header whose dd= member is arbitrarily large (or contains an arbitrarily large number of pairs), forcing unbounded CPU and memory consumption per request and enabling a remote Denial of Service. tracecontext extraction is enabled by default in affected tracers, so any internet-facing service instrumented with an affected version is exposed unless tracecontext has been explicitly removed from the propagation style configuration. Patches This is resolved in version 0.3.3 and later of the dd-trace-rs library. Workarounds If you cannot upgrade immediately: 1. Disable tracecontext extraction by setting…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gpwf-4h98-v82q
- Revision 1 · created ·
Published from osv record GHSA-gpwf-4h98-v82q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54788 Advisory: datadog-opentelemetry has unbounded W3C tracestate parsing that may lead to DoS IDs: CVE-2026-54788, GHSA-gpwf-4h98-v82q Record: https://patchnext.com/advisories/cve-2026-54788 (revision 2, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datadog-opentelemetry 0.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io datadog-opentelemetry: affected >= 0.1.0, < 0.3.3; fixed in 0.3.3 ## Suggested inspection (read-only) - crates.io datadog-opentelemetry: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datadog-opentelemetry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gpwf-4h98-v82q (OSV record GHSA-gpwf-4h98-v82q lists affected ranges: crates.io datadog-opentelemetry >=0.1.0 <0.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-gpwf-4h98-v82q (GitHub-reviewed advisory GHSA-gpwf-4h98-v82q lists affected ranges: crates.io datadog-opentelemetry >=0.1.0 <0.3.3) Commands are suggestions: review each one before running it.
Loading voting…