Skip to content

← Actionable
Medium, CVSS 4.4

CoreWCF: Unix Domain Socket PosixIdentity transport accepts connections that skip the security upgrade

CVE-2026-54776GHSA-wjpq-6766-7f5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (corewcf.unixdomainsocket 1.9.1, 1.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-54776: 0.15% estimated exploitation activity in the next 30 days; percentile 4.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A CoreWCF service hosted on Unix Domain Sockets with the PosixIdentity client credential type (UnixDomainSocketBinding with Security.Mode = TransportCredentialOnly and Security.Transport.ClientCredentialType = PosixIdentity) does not require the client to perform the application/unixposix stream upgrade before dispatching messages. Patches Fixed in CoreWCF v1.8.1 and v1.9.1 Workarounds Restrict filesystem access to the UDS socket file using owner/group/mode (e.g. chmod 0660 plus a dedicated group) so that only the POSIX users who are already authorized to invoke the service can connect at all. This makes the missing-upgrade behaviour equivalent to the operating system’s filesystem permissions instead of relying on framing-layer identity checks. Avoid relying on ServiceSecurityContext.PrimaryIdentity for authorization decisions, or back it up with an authentication-required authorization policy that rejects anonymous principals.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wjpq-6766-7f5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54776

Advisory: CoreWCF: Unix Domain Socket PosixIdentity transport accepts connections that skip the security upgrade
IDs: CVE-2026-54776, GHSA-wjpq-6766-7f5j
Record: https://patchnext.com/advisories/cve-2026-54776 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: corewcf.unixdomainsocket 1.9.1, 1.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet corewcf.unixdomainsocket: affected < 1.8.1; >= 1.9.0, < 1.9.1; fixed in 1.8.1, 1.9.1

## Suggested inspection (read-only)
- NuGet corewcf.unixdomainsocket: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on corewcf.unixdomainsocket.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wjpq-6766-7f5j (GitHub-reviewed advisory GHSA-wjpq-6766-7f5j lists affected ranges: NuGet corewcf.unixdomainsocket >=0 =1.9.0 <1.9.1)

Commands are suggestions: review each one before running it.

Loading voting…