Skip to content

← Actionable
Critical, CVSS 10.0amended

Langroid: Sandbox Escape to Remote Code Execution via Incomplete eval() Mitigation in TableChatAgent

CVE-2026-54769GHSA-q9p7-wqxg-mrhc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langroid 0.65.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langroid

    Affected
    <= 0.65.1
    Fixed in
    0.65.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-54769: 0.91% estimated exploitation activity in the next 30 days; percentile 60.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Advisory Details Title: Sandbox Escape to Remote Code Execution via Incomplete eval() Mitigation in TableChatAgent Description: Summary Langroid is vulnerable to a critical Sandbox Escape leading to Remote Code Execution (RCE) in its TableChatAgent and VectorStore capabilities. When these agents evaluate LLM-generated tool messages with fulleval=True, they attempt to sandbox the execution by explicitly setting locals to an empty dictionary {} inside Python's eval() function. However, this relies on an incomplete understanding of Python's execution model. Because builtins is not explicitly scrubbed from the globals dictionary mapping, Python implicitly injects all built-ins during execution, granting full access to functions like import('os').system(). Since TableChatAgent.pandaseval() executes external LLM outputs natively, this bypass permits any attacker providing prompt payload to achieve unauthenticated RCE on the host system. Details The root cause lies in how the framework…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q9p7-wqxg-mrhc

  2. Revision 2 · amended ·

    Amended from osv record GHSA-q9p7-wqxg-mrhc

  3. Revision 1 · created ·

    Published from ghsa record GHSA-q9p7-wqxg-mrhc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54769

Advisory: Langroid: Sandbox Escape to Remote Code Execution via Incomplete `eval()` Mitigation in TableChatAgent
IDs: CVE-2026-54769, GHSA-q9p7-wqxg-mrhc
Record: https://patchnext.com/advisories/cve-2026-54769 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langroid 0.65.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langroid: affected <= 0.65.1; fixed in 0.65.2

## Suggested inspection (read-only)
- `python -m pip show langroid`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langroid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q9p7-wqxg-mrhc (GitHub-reviewed advisory GHSA-q9p7-wqxg-mrhc lists affected ranges: PyPI langroid >=0 <=0.65.1)
- Verified: https://osv.dev/vulnerability/GHSA-q9p7-wqxg-mrhc (OSV record GHSA-q9p7-wqxg-mrhc lists affected ranges: PyPI langroid >=0 <0.65.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…