nx graph dev server permissive CORS policy
CVE-2026-54753GHSA-g2r8-wvmj-jf5w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nx 23.0.0-beta.2, 22.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nx
- Affected
- >= 17.0.4, < 22.7.2>= 23.0.0-beta.0, < 23.0.0-beta.2
- Fixed in
- 23.0.0-beta.2, 22.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g2r8-wvmj-jf5w lists affected ranges: npm nx >=17.0.4 =23.0.0-beta.0 <23.0.0-beta.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-54753: 1.44% estimated exploitation activity in the next 30 days; percentile 73.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The local HTTP server started by nx graph sent Access-Control-Allow-Origin: on every response, letting any website a developer visited read the server's responses cross-origin — including the full project graph and the output of the /help endpoint, which runs a target's configured help command. The practical impact is typically cross-origin information disclosure, but can be arbitrary command injection in rare cases. Severity Exploitation requires the developer to be running nx graph and to visit an attacker page. Any execution beyond benign help commands also requires a malicious target to already be present in the workspace (see Details). Affected & Patched Versions Package: nx (npm). - Affected: = 17.0.4, < 22.7.2 and = 23.0.0-beta.0, < 23.0.0-beta.2 - Patched: 22.7.2+ (backport) and 23.0.0 (first in 23.0.0-beta.2) The wildcard CORS header was introduced in 17.0.4; the /help execution endpoint in 19.4.0. The 21.x line is not patched — 21.x users should upgrade to 22.7.2 or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g2r8-wvmj-jf5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54753 Advisory: `nx graph` dev server permissive CORS policy IDs: CVE-2026-54753, GHSA-g2r8-wvmj-jf5w Record: https://patchnext.com/advisories/cve-2026-54753 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nx 23.0.0-beta.2, 22.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nx: affected >= 17.0.4, < 22.7.2; >= 23.0.0-beta.0, < 23.0.0-beta.2; fixed in 23.0.0-beta.2, 22.7.2 ## Suggested inspection (read-only) - `npm ls nx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g2r8-wvmj-jf5w (GitHub-reviewed advisory GHSA-g2r8-wvmj-jf5w lists affected ranges: npm nx >=17.0.4 =23.0.0-beta.0 <23.0.0-beta.2) Commands are suggestions: review each one before running it.
Loading voting…