@phun-ky/defaults-deep Has a Prototype Pollution issue via Unsafe Recursive Property Merging
CVE-2026-54737GHSA-mj3g-7xcc-x4vh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@phun-ky/defaults-deep 2.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.0.5
- Fixed in
- 2.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mj3g-7xcc-x4vh lists affected ranges: npm @phun-ky/defaults-deep >=0 <2.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-54737: 0.46% estimated exploitation activity in the next 30 days; percentile 39.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A prototype pollution vulnerability exists in @phun-ky/defaults-deep prior to version 2.0.5. The library recursively merged user-supplied objects without filtering unsafe property names such as proto, constructor, and prototype. An attacker able to supply crafted input could cause properties to be written to Object.prototype, resulting in prototype pollution affecting all objects within the running process. Applications that pass untrusted input to defaultsDeep() may be impacted. Depending on how the application uses merged objects, this could lead to unexpected behavior, logic bypasses, denial of service, or other security issues. Patches This issue has been fixed in version 2.0.5. Users should upgrade to version 2.0.5 or later. The fix prevents unsafe prototype-related keys (proto, constructor, and prototype) from being processed during recursive merge operations and includes regression tests covering known prototype pollution vectors. Workarounds Users unable to upgrade…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mj3g-7xcc-x4vh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54737 Advisory: @phun-ky/defaults-deep Has a Prototype Pollution issue via Unsafe Recursive Property Merging IDs: CVE-2026-54737, GHSA-mj3g-7xcc-x4vh Record: https://patchnext.com/advisories/cve-2026-54737 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @phun-ky/defaults-deep 2.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @phun-ky/defaults-deep: affected < 2.0.5; fixed in 2.0.5 ## Suggested inspection (read-only) - `npm ls @phun-ky/defaults-deep --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @phun-ky/defaults-deep. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mj3g-7xcc-x4vh (GitHub-reviewed advisory GHSA-mj3g-7xcc-x4vh lists affected ranges: npm @phun-ky/defaults-deep >=0 <2.0.5) Commands are suggestions: review each one before running it.
Loading voting…