silverstripe/userforms vulnerable to remote code execution via userforms email subject
CVE-2026-54721GHSA-g8wr-r2v2-vqc6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/userforms 7.1.1, 7.0.7, 6.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/userforms
- Affected
- < 6.4.9>= 7.0.0, < 7.0.7>= 7.1.0, < 7.1.1
- Fixed in
- 7.1.1, 7.0.7, 6.4.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g8wr-r2v2-vqc6 lists affected ranges: Packagist silverstripe/userforms >=0 =7.0.0 =7.1.0 <7.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8wr-r2v2-vqc6 lists affected ranges: Packagist silverstripe/userforms >=0 =7.0.0 =7.1.0 <7.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54721: 0.73% estimated exploitation activity in the next 30 days; percentile 54.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The userform email subject field in the CMS is vulnerable to a specially crafted payload being used to run arbitrary code on the server. Reported by Jack Wallace from Bastion Security
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g8wr-r2v2-vqc6
- Revision 1 · created ·
Published from osv record GHSA-g8wr-r2v2-vqc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54721 Advisory: silverstripe/userforms vulnerable to remote code execution via userforms email subject IDs: CVE-2026-54721, GHSA-g8wr-r2v2-vqc6 Record: https://patchnext.com/advisories/cve-2026-54721 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/userforms 7.1.1, 7.0.7, 6.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/userforms: affected < 6.4.9; >= 7.0.0, < 7.0.7; >= 7.1.0, < 7.1.1; fixed in 7.1.1, 7.0.7, 6.4.9 ## Suggested inspection (read-only) - Packagist silverstripe/userforms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/userforms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g8wr-r2v2-vqc6 (OSV record GHSA-g8wr-r2v2-vqc6 lists affected ranges: Packagist silverstripe/userforms >=0 =7.0.0 =7.1.0 <7.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g8wr-r2v2-vqc6 (GitHub-reviewed advisory GHSA-g8wr-r2v2-vqc6 lists affected ranges: Packagist silverstripe/userforms >=0 =7.0.0 =7.1.0 <7.1.1) Commands are suggestions: review each one before running it.
Loading voting…