Skip to content

← Actionable
Low, CVSS 2.4amended

PGHoard: Password written to debug log

CVE-2026-54711GHSA-mpx4-jmpr-vm8v

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pghoard

    Affected
    <= 2.1.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54711: 0.16% estimated exploitation activity in the next 30 days; percentile 4.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using .pgpass, database connection information including the username and password will be logged at the debug level. Patches Upgrade to version 2.7.1 or greater. Workarounds Filter out debug-level logs. References This issue was discovered by BugCrowd user DRAKOKORIAN.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mpx4-jmpr-vm8v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mpx4-jmpr-vm8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54711

Advisory: PGHoard: Password written to debug log
IDs: CVE-2026-54711, GHSA-mpx4-jmpr-vm8v
Record: https://patchnext.com/advisories/cve-2026-54711 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pghoard: affected <= 2.1.0

## Suggested inspection (read-only)
- `python -m pip show pghoard`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pghoard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mpx4-jmpr-vm8v (OSV record GHSA-mpx4-jmpr-vm8v lists affected ranges: PyPI pghoard >=0 <=2.1.0)
- Verified: https://github.com/advisories/GHSA-mpx4-jmpr-vm8v (GitHub-reviewed advisory GHSA-mpx4-jmpr-vm8v lists affected ranges: PyPI pghoard >=0 <=2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…