datamodel-code-generator vulnerable to SSRF via --url: no host/IP validation, follows redirects
CVE-2026-54691GHSA-rfr2-mq9m-x2qx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.61.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.9.1, <= 0.60.2
- Fixed in
- 0.61.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfr2-mq9m-x2qx lists affected ranges: PyPI datamodel-code-generator >=0.9.1 <=0.60.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-54691: 0.26% estimated exploitation activity in the next 30 days; percentile 17.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary datamodel-code-generator's built-in HTTP fetcher (http.getbody) issues an httpx.GET against any URL passed to --url (or reached via a redirect chain) with no allow-list, no deny-list, no IP/host validation, and followredirects=True. Loopback addresses, RFC1918 ranges, link-local (169.254.169.254 cloud metadata), unique-local IPv6 and any other network-accessible target are all reachable. The JSON/YAML response body is parsed as a schema and reflected into the generated .py source, exfiltrating the response to anyone with access to that file (commonly committed to a repository). Details Sink: src/datamodelcodegenerator/http.py, getbody (lines 31–61, at tag 0.60.1 / commit a321547e): - (A) follows redirects unconditionally — a public URL → 302 → internal address chain works. - (B) the only filter is rejecting text/html. Non-HTML internal endpoints (JSON APIs, cloud metadata, admin services) pass through. - (C) the response body becomes the schema; its title, description,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rfr2-mq9m-x2qx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54691 Advisory: datamodel-code-generator vulnerable to SSRF via --url: no host/IP validation, follows redirects IDs: CVE-2026-54691, GHSA-rfr2-mq9m-x2qx Record: https://patchnext.com/advisories/cve-2026-54691 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.61.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datamodel-code-generator: affected >= 0.9.1, <= 0.60.2; fixed in 0.61.0 ## Suggested inspection (read-only) - `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datamodel-code-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfr2-mq9m-x2qx (GitHub-reviewed advisory GHSA-rfr2-mq9m-x2qx lists affected ranges: PyPI datamodel-code-generator >=0.9.1 <=0.60.2) Commands are suggestions: review each one before running it.
Loading voting…