Skip to content

← Actionable
High, CVSS 8.2

datamodel-code-generator vulnerable to SSRF via JSON-Schema $ref to HTTP URL (silent by default)

CVE-2026-54690GHSA-954p-556p-r752

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.61.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-54690: 0.39% estimated exploitation activity in the next 30 days; percentile 32.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary JSON-Schema $ref values pointing at HTTP or HTTPS URLs are silently dereferenced by datamodel-code-generator with no IP/host validation, no scheme allow-list, and redirects followed unconditionally. The --allow-remote-refs gate added in 0.56.0 defaults to None, which only emits a deprecation warning and then fetches the URL anyway; only explicit --allow-remote-refs=false blocks the request. The fetched body is parsed as a sub-schema and reflected verbatim into the generated .py source. As a result, any JSON-Schema document the developer feeds to datamodel-codegen — including documents authored by an attacker — can pivot to arbitrary internal addresses and leak the response into the generated code, with no developer cooperation beyond running the tool. Details Sink: src/datamodelcodegenerator/parser/jsonschema.py, getrefbody (lines 4776–4793, at tag 0.60.1 / commit a321547e): - (A) emits a deprecation warning when allowremoterefs is its default (None); execution falls through…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-954p-556p-r752

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54690

Advisory: datamodel-code-generator vulnerable to SSRF via JSON-Schema `$ref` to HTTP URL (silent by default)
IDs: CVE-2026-54690, GHSA-954p-556p-r752
Record: https://patchnext.com/advisories/cve-2026-54690 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.61.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI datamodel-code-generator: affected >= 0.9.1, <= 0.60.2; fixed in 0.61.0

## Suggested inspection (read-only)
- `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on datamodel-code-generator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-954p-556p-r752 (GitHub-reviewed advisory GHSA-954p-556p-r752 lists affected ranges: PyPI datamodel-code-generator >=0.9.1 <=0.60.2)

Commands are suggestions: review each one before running it.

Loading voting…