Logging operator has Fluentd configuration injection that allows remote code execution
CVE-2026-54680GHSA-mjqf-28ph-426h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kube-logging/logging-operator 0.0.0-20260608145523-cf437d7f1e05), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kube-logging/logging-operator
- Affected
- < 0.0.0-20260608145523-cf437d7f1e05
- Fixed in
- 0.0.0-20260608145523-cf437d7f1e05
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mjqf-28ph-426h lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6142 lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mjqf-28ph-426h lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-54680: 0.78% estimated exploitation activity in the next 30 days; percentile 56.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Fluentd configuration renderer in Logging operator writes strings from CRDs such as Flow directly into fluent.conf without escaping them. As a result, a user who can create Flow resources can inject Fluentd configuration by providing values that contain newlines. In the confirmed path, a value in recordtransformer.records can close the current <record / <filter block and add a new <match block. By specifying Fluentd's core @type exec plugin in that injected block, an attacker can execute arbitrary commands inside the Fluentd aggregator. Details The issue is in FluentRender in pkg/sdk/logging/model/render/fluent.go. https://github.com/kube-logging/logging-operator/blob/98275d2984aa8d731c4c975b8006aa433fc7bafa/pkg/sdk/logging/model/render/fluent.go#L60-L87 Each parameter is rendered as key value, but values are not quoted, and newlines or characters such as < and are not rejected. In addition, indentedf builds the string with fmt.Sprintf and then splits it on \n, so…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mjqf-28ph-426h
- Revision 2 · amended ·
Amended from osv record GO-2026-6142
- Revision 1 · created ·
Published from osv record GHSA-mjqf-28ph-426h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54680 Advisory: Logging operator has Fluentd configuration injection that allows remote code execution IDs: CVE-2026-54680, GHSA-mjqf-28ph-426h Record: https://patchnext.com/advisories/cve-2026-54680 (revision 3, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kube-logging/logging-operator 0.0.0-20260608145523-cf437d7f1e05. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kube-logging/logging-operator: affected < 0.0.0-20260608145523-cf437d7f1e05; fixed in 0.0.0-20260608145523-cf437d7f1e05 ## Suggested inspection (read-only) - Go github.com/kube-logging/logging-operator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kube-logging/logging-operator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mjqf-28ph-426h (OSV record GHSA-mjqf-28ph-426h lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6142 (OSV record GO-2026-6142 lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05 (fixed)) - Verified: https://github.com/advisories/GHSA-mjqf-28ph-426h (GitHub-reviewed advisory GHSA-mjqf-28ph-426h lists affected ranges: Go github.com/kube-logging/logging-operator >=0 <0.0.0-20260608145523-cf437d7f1e05) Commands are suggestions: review each one before running it.
Loading voting…