swagger-typescript-api vulnerable to code injection via unescaped enum string values
CVE-2026-54664GHSA-5f94-x226-ccpm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (swagger-typescript-api 13.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 13.12.1
- Fixed in
- 13.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5f94-x226-ccpm lists affected ranges: npm swagger-typescript-api >=0 <=13.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-54664: 0.48% estimated exploitation activity in the next 30 days; percentile 41.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary swagger-typescript-api interpolates components.schemas..enum[i] string values into the body of generated TypeScript enum declarations without escaping. A malicious enum value can close the enclosing string literal, terminate the enum body, and inject a bare-block IIFE that executes at module load the first time the generated client is imported. The trigger requires no instantiation and no method call — only an import of the generated module. The attacker controls the OpenAPI spec (remote --url, third-party / public spec, multi-tenant platform); the victim is whoever runs the generator and imports the result (the developer, their CI runner, or any downstream consumer of the generated package). Impact is arbitrary code execution with the importing process's privileges — read any file the importer can read, write any file, exfiltrate secrets, etc. Details The root cause is Ts.StringValue in src/configuration.ts:250: It wraps a value in double quotes with zero escaping — no…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5f94-x226-ccpm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54664 Advisory: swagger-typescript-api vulnerable to code injection via unescaped enum string values IDs: CVE-2026-54664, GHSA-5f94-x226-ccpm Record: https://patchnext.com/advisories/cve-2026-54664 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: swagger-typescript-api 13.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm swagger-typescript-api: affected <= 13.12.1; fixed in 13.12.2 ## Suggested inspection (read-only) - `npm ls swagger-typescript-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on swagger-typescript-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5f94-x226-ccpm (GitHub-reviewed advisory GHSA-5f94-x226-ccpm lists affected ranges: npm swagger-typescript-api >=0 <=13.12.1) Commands are suggestions: review each one before running it.
Loading voting…