swagger-typescript-api vulnerable to code injection via unescaped servers[0].url in axios http-client template
CVE-2026-54661GHSA-38c3-wv3c-v3xj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (swagger-typescript-api 13.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 13.12.1
- Fixed in
- 13.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38c3-wv3c-v3xj lists affected ranges: npm swagger-typescript-api >=0 <=13.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-54661: 0.48% estimated exploitation activity in the next 30 days; percentile 41.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary swagger-typescript-api interpolates servers[0].url directly into a TypeScript string literal inside the HttpClient constructor body of the generated axios client (templates/base/http-clients/axios-http-client.ejs:71), without any escaping. A malicious URL containing a " closes the string literal and exposes the surrounding object-literal argument of axios.create({...}) to injection. A computed property key whose value is an IIFE executes arbitrary code every time new HttpClient() (or new Api(), which extends HttpClient) is constructed. The attacker controls the OpenAPI spec; the victim is any consumer of the generated client. Impact is arbitrary code execution with the importing process's privileges. This is the axios sibling of the previously reported fetch-client RCE — same upstream variable (apiConfig.baseUrl, sourced from servers[0].url), same root cause class (raw <%~ % interpolation of unescaped spec strings), different template file and different lifecycle frame…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-38c3-wv3c-v3xj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54661 Advisory: swagger-typescript-api vulnerable to code injection via unescaped `servers[0].url` in axios http-client template IDs: CVE-2026-54661, GHSA-38c3-wv3c-v3xj Record: https://patchnext.com/advisories/cve-2026-54661 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: swagger-typescript-api 13.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm swagger-typescript-api: affected <= 13.12.1; fixed in 13.12.2 ## Suggested inspection (read-only) - `npm ls swagger-typescript-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on swagger-typescript-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-38c3-wv3c-v3xj (GitHub-reviewed advisory GHSA-38c3-wv3c-v3xj lists affected ranges: npm swagger-typescript-api >=0 <=13.12.1) Commands are suggestions: review each one before running it.
Loading voting…