Skip to content

← Actionable
Medium, CVSS 6.9amended

Pagy I18n locale option is not validated before being used in a file path

CVE-2026-54659GHSA-2xmw-f8j8-wfxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pagy 43.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems pagy

    Affected
    >= 43.0.0, < 43.5.6
    Fixed in
    43.5.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54659: 0.37% estimated exploitation activity in the next 30 days; percentile 30.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Pagy::I18n.locale= did not validate its argument before using it as a path component to load the matching dictionary file (<locale.yml). An application that assigns untrusted input to the locale — e.g. the common pattern Pagy::I18n.locale = params[:locale] — let that input influence which file Pagy attempted to load. Details The setter stored the value as-is, and the loader joined it into a path and read it: Because the locale was used verbatim, a value such as an absolute path or a ../-style string redirected the lookup outside the locales directory. Pagy's subsequent structural check (dictionary['pagy']['p11n']) prevents the file's contents from being returned, so this is not a direct file read. Fixed in 43.5.6 by constraining the locale to a BCP 47 shape before use: Any non-matching value (including nil) resolves to the default locale and never reaches the file lookup. PoC In an application that sets Pagy::I18n.locale = params[:locale], the loader appends .yml and reads…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2xmw-f8j8-wfxc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2xmw-f8j8-wfxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54659

Advisory: Pagy I18n locale option is not validated before being used in a file path
IDs: CVE-2026-54659, GHSA-2xmw-f8j8-wfxc
Record: https://patchnext.com/advisories/cve-2026-54659 (revision 3, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pagy 43.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems pagy: affected >= 43.0.0, < 43.5.6; fixed in 43.5.6

## Suggested inspection (read-only)
- RubyGems pagy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pagy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2xmw-f8j8-wfxc (OSV record GHSA-2xmw-f8j8-wfxc lists affected ranges: RubyGems pagy >=43.0.0 <43.5.6 (fixed))
- Verified: https://github.com/advisories/GHSA-2xmw-f8j8-wfxc (GitHub-reviewed advisory GHSA-2xmw-f8j8-wfxc lists affected ranges: RubyGems pagy >=43.0.0 <43.5.6)

Commands are suggestions: review each one before running it.

Loading voting…