datamodel-code-generator vulnerable to code execution on import via unescaped validators entries in --extra-template-data
CVE-2026-54656GHSA-8m8r-38jm-f355
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.60.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.52.1, <= 0.60.1
- Fixed in
- 0.60.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8m8r-38jm-f355 lists affected ranges: PyPI datamodel-code-generator >=0.52.1 <=0.60.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54656: 0.25% estimated exploitation activity in the next 30 days; percentile 16.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When the Pydantic v2 output mode is in use, datamodel-code-generator reads a validators array from each model entry in the --extra-template-data file and synthesises a Pydantic @fieldvalidator(...) decorator from each entry. The field names and the validator mode are interpolated into the decorator call wrapped in unescaped single quotes. A value containing ' breaks out of the string literal, letting an attacker emit an arbitrary positional Python expression into the decorator. The expression is evaluated at class-definition time, i.e. the moment the developer imports the generated module. This is the same trust model as the recently-published GHSA-wjv6-jcfj-mf9r (extras-file comment injection) but the impact is full RCE rather than a docstring leak. Details Sink: src/datamodelcodegenerator/model/pydanticv2/basemodel.py, processvalidators (lines 405–449, at tag 0.60.1 / commit a321547e): The strings from (A) and (B) flow verbatim into…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8m8r-38jm-f355
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54656 Advisory: `datamodel-code-generator` vulnerable to code execution on import via unescaped `validators` entries in --extra-template-data IDs: CVE-2026-54656, GHSA-8m8r-38jm-f355 Record: https://patchnext.com/advisories/cve-2026-54656 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.60.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datamodel-code-generator: affected >= 0.52.1, <= 0.60.1; fixed in 0.60.2 ## Suggested inspection (read-only) - `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datamodel-code-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8m8r-38jm-f355 (GitHub-reviewed advisory GHSA-8m8r-38jm-f355 lists affected ranges: PyPI datamodel-code-generator >=0.52.1 <=0.60.1) Commands are suggestions: review each one before running it.
Loading voting…