Skip to content

← Actionable
High, CVSS 8.6amended

openhole-server vulnerable to path traversal via URL-decoded request path

CVE-2026-54650GHSA-fh2f-xfxc-q9cc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/bablilayoub/openhole 0.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-54650: 0.53% estimated exploitation activity in the next 30 days; percentile 44.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary openhole-server forwarded the URL-decoded request path (r.URL.Path) to tunnel clients instead of the original request-target. Percent-encoded dot-segments (%2e) and separators (%2f) were decoded to ../ and / before reaching the local service. Go's ServeMux rejects literal ../ paths, but percent-encoded traversal sequences bypassed this and were delivered to backends as working path traversal. Impact An unauthenticated remote attacker could read files outside the published web root on tunneled local services that resolve paths without canonicalization. Example: - /%2e%2e/secret.txt → file outside web root - /%2e%2e/%2e%2e/etc/passwd → sensitive files Encoded slashes (/a%2fb) could also bypass path-based access controls. Fix v0.1.2 forwards r.URL.EscapedPath() on the server and preserves the request-target on the CLI client. Users should upgrade both openhole-server and the openhole CLI to v0.1.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fh2f-xfxc-q9cc

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6135

  3. Revision 1 · created ·

    Published from osv record GHSA-fh2f-xfxc-q9cc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54650

Advisory: openhole-server vulnerable to path traversal via URL-decoded request path
IDs: CVE-2026-54650, GHSA-fh2f-xfxc-q9cc
Record: https://patchnext.com/advisories/cve-2026-54650 (revision 3, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/bablilayoub/openhole 0.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/bablilayoub/openhole: affected <= 0.1.1; fixed in 0.1.2

## Suggested inspection (read-only)
- Go github.com/bablilayoub/openhole: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/bablilayoub/openhole.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fh2f-xfxc-q9cc (OSV record GHSA-fh2f-xfxc-q9cc lists affected ranges: Go github.com/bablilayoub/openhole >=0 <0.1.2 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6135 (OSV record GO-2026-6135 lists affected ranges: Go github.com/bablilayoub/openhole >=0 <0.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-fh2f-xfxc-q9cc (GitHub-reviewed advisory GHSA-fh2f-xfxc-q9cc lists affected ranges: Go github.com/bablilayoub/openhole >=0 <=0.1.1)

Commands are suggestions: review each one before running it.

Loading voting…