OpenRemote has Cross-Realm User Information Disclosure in UserResourceImpl
CVE-2026-54641GHSA-xqr9-4wvv-gvch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.openremote:openremote-manager 1.24.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.openremote:openremote-manager
- Affected
- < 1.24.2
- Fixed in
- 1.24.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqr9-4wvv-gvch lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.24.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-54641: 0.29% estimated exploitation activity in the next 30 days; percentile 21.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A realm admin of tenant B can read the profile, client roles, and realm roles of any user in any other realm (including the master realm) by supplying the target user's UUID in the REST API path. Three read endpoints in UserResourceImpl check whether the caller holds the read:admin role but omit a check that the target user belongs to the caller's own realm. The vulnerability enables cross-tenant user enumeration and privilege-level reconnaissance. On a multi-tenant deployment the master realm administrator account is reachable from any tenant realm admin. Details The affected file is manager/src/main/java/org/openremote/manager/security/UserResourceImpl.java. Three methods are missing an authenticated-realm guard: get (line 102): public User get(RequestParams requestParams, String realm, String userId) { boolean hasAdminReadRole = hasResourceRole(ClientRole.READADMIN.getValue(), Constants.KEYCLOAKCLIENTID); if (!hasAdminReadRole && !Objects.equals(getUserId(), userId)) {…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xqr9-4wvv-gvch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54641 Advisory: OpenRemote has Cross-Realm User Information Disclosure in UserResourceImpl IDs: CVE-2026-54641, GHSA-xqr9-4wvv-gvch Record: https://patchnext.com/advisories/cve-2026-54641 (revision 1, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.openremote:openremote-manager 1.24.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.openremote:openremote-manager: affected < 1.24.2; fixed in 1.24.2 ## Suggested inspection (read-only) - Maven io.openremote:openremote-manager: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.openremote:openremote-manager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xqr9-4wvv-gvch (GitHub-reviewed advisory GHSA-xqr9-4wvv-gvch lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.24.2) Commands are suggestions: review each one before running it.
Loading voting…