Skip to content

← Actionable
High, CVSS 7.5amended

SIPSorcery: Malformed UDP packet on the RTP/ICE socket can remotely terminate a media session (DoS)

CVE-2026-54632GHSA-28gm-jrmw-xx93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sipsorcery 10.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-54632: 0.72% estimated exploitation activity in the next 30 days; percentile 53.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A single malformed inbound UDP packet on the RTP/ICE socket can remotely terminate an active RTP or WebRTC media session. The packet receive handler indexes packet (and STUN attribute) bytes without sufficient length checks and throws, and the UDP receive loop converted any such exception into a channel Close rather than dropping the packet. One small, unauthenticated packet therefore ends the media session. This is reachable during ICE connectivity checks — before the DTLS handshake and before any STUN MESSAGE-INTEGRITY verification. Because the RTP/ICE port is shared/advertised in the ICE candidates, a peer or on-path attacker can reach it (exposure is lower for a blind off-path attacker that must first learn the ephemeral port). Impact is availability only — no loss of confidentiality or integrity. Affected versions NuGet package SIPSorcery <= 10.0.8. Patches Fixed in 10.0.9. Root cause Two issues combine: 1. Unchecked indexing of untrusted bytes. -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-28gm-jrmw-xx93

  2. Revision 1 · created ·

    Published from osv record GHSA-28gm-jrmw-xx93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54632

Advisory: SIPSorcery: Malformed UDP packet on the RTP/ICE socket can remotely terminate a media session (DoS)
IDs: CVE-2026-54632, GHSA-28gm-jrmw-xx93
Record: https://patchnext.com/advisories/cve-2026-54632 (revision 2, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sipsorcery 10.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet sipsorcery: affected <= 10.0.8; fixed in 10.0.9

## Suggested inspection (read-only)
- NuGet sipsorcery: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sipsorcery.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-28gm-jrmw-xx93 (OSV record GHSA-28gm-jrmw-xx93 lists affected ranges: NuGet sipsorcery >=0 <10.0.9 (fixed))
- Verified: https://github.com/advisories/GHSA-28gm-jrmw-xx93 (GitHub-reviewed advisory GHSA-28gm-jrmw-xx93 lists affected ranges: NuGet sipsorcery >=0 <=10.0.8)

Commands are suggestions: review each one before running it.

Loading voting…