datamodel-code-generator vulnerable to code injection via unescaped carriage return in GraphQL Union description
CVE-2026-54621GHSA-j884-q54q-mmx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (datamodel-code-generator 0.60.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.25.0, < 0.60.1
- Fixed in
- 0.60.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j884-q54q-mmx3 lists affected ranges: PyPI datamodel-code-generator >=0.25.0 <0.60.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54621: 0.21% estimated exploitation activity in the next 30 days; percentile 11.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary datamodel-code-generator is vulnerable to code injection when generating Python models from an attacker-controlled GraphQL schema. A description on a Union type, written in the regular-string form ("...") with a literal \r escape, is rendered into a Python
comment by a Jinja2 filter that handles only \n. Python's tokenizer treats a bare CR as a physical-line terminator, so the comment ends at the \r and the text after it is parsed as module-level Python. The injected code executes at import time of the generated .py, in the context of any consumer that imports the model. No special CLI flags are required. This affects versions =0.25.0, <0.60.1 and is fixed in 0.60.1. Details The vulnerable output was generated by the GraphQL Union templates: - src/datamodelcodegenerator/model/template/UnionTypeStatement.jinja2 - src/datamodelcodegenerator/model/template/UnionTypeAliasAnnotation.jinja2 - src/datamodelcodegenerator/model/template/UnionTypeAliasType.jinja2 Before 0.60.1, Union…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j884-q54q-mmx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54621 Advisory: `datamodel-code-generator` vulnerable to code injection via unescaped carriage return in GraphQL Union description IDs: CVE-2026-54621, GHSA-j884-q54q-mmx3 Record: https://patchnext.com/advisories/cve-2026-54621 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: datamodel-code-generator 0.60.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI datamodel-code-generator: affected >= 0.25.0, < 0.60.1; fixed in 0.60.1 ## Suggested inspection (read-only) - `python -m pip show datamodel-code-generator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on datamodel-code-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j884-q54q-mmx3 (GitHub-reviewed advisory GHSA-j884-q54q-mmx3 lists affected ranges: PyPI datamodel-code-generator >=0.25.0 <0.60.1) Commands are suggestions: review each one before running it.
Loading voting…