sqlite3-ruby has Use-After-Free in SQLite Aggregate Function Callbacks
CVE-2026-54620GHSA-j7fr-3v8c-3qc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3 2.9.5; sqlite3-ruby 2.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sqlite3
- Affected
- >= 2.1.0, <= 2.9.4
- Fixed in
- 2.9.5
RubyGems sqlite3-ruby
- Affected
- >= 2.1.0, <= 2.9.4
- Fixed in
- 2.9.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j7fr-3v8c-3qc3 lists affected ranges: RubyGems sqlite3-ruby >=2.1.0 =2.1.0 <2.9.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j7fr-3v8c-3qc3 lists affected ranges: RubyGems sqlite3-ruby >=2.1.0 =2.1.0 <=2.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54620: 0.14% estimated exploitation activity in the next 30 days; percentile 3.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Using Database#createaggregate, #createaggregatehandler, or Database#defineaggregator to define an aggregate function, and then using an open statement calling that function after the database has been explicitly closed will result in an invalid memory read and a segmentation fault. Mitigation Upgrade to sqlite3 gem v2.9.5 or later. As a workaround, avoid using an aggregate function after closing the database. Severity The sqlite3-ruby maintainers assess this as Low severity. It is reliably triggered after GC when code is structured in a particular way. There is no known general exploit that could be used as a denial of service attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j7fr-3v8c-3qc3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j7fr-3v8c-3qc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54620 Advisory: sqlite3-ruby has Use-After-Free in SQLite Aggregate Function Callbacks IDs: CVE-2026-54620, GHSA-j7fr-3v8c-3qc3 Record: https://patchnext.com/advisories/cve-2026-54620 (revision 3, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sqlite3 2.9.5; sqlite3-ruby 2.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sqlite3: affected >= 2.1.0, <= 2.9.4; fixed in 2.9.5 - RubyGems sqlite3-ruby: affected >= 2.1.0, <= 2.9.4; fixed in 2.9.5 ## Suggested inspection (read-only) - RubyGems sqlite3: check the installed version with your package manager. - RubyGems sqlite3-ruby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sqlite3, sqlite3-ruby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j7fr-3v8c-3qc3 (OSV record GHSA-j7fr-3v8c-3qc3 lists affected ranges: RubyGems sqlite3-ruby >=2.1.0 =2.1.0 <2.9.5 (fixed)) - Verified: https://github.com/advisories/GHSA-j7fr-3v8c-3qc3 (GitHub-reviewed advisory GHSA-j7fr-3v8c-3qc3 lists affected ranges: RubyGems sqlite3-ruby >=2.1.0 =2.1.0 <=2.9.4) Commands are suggestions: review each one before running it.
Loading voting…