Skip to content

← Actionable
Low, CVSS 2.0amended

sqlite3-ruby has Use-After-Free When Redefining SQLite Functions with Different Arity

CVE-2026-54619GHSA-28hh-pr2h-2w89

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3 2.9.5; sqlite3-ruby 2.9.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sqlite3

    Affected
    <= 2.9.4
    Fixed in
    2.9.5
  • RubyGems sqlite3-ruby

    Affected
    <= 2.9.4
    Fixed in
    2.9.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54619: 0.14% estimated exploitation activity in the next 30 days; percentile 3.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Using Database#createfunction or Database#definefunction to define the same function name more than once with different numbers of arguments ("arity") or text encodings will result in a invalid memory read and a segmentation fault. Mitigation Upgrade to sqlite3 gem v2.9.5 or later. As a workaround, avoid defining multiple custom functions with the same name (varying numbers of arguments or encoding). Severity The sqlite3-ruby maintainers assess this as Low severity. It is reliably triggered after GC when code is structured in a particular way. There is no known general exploit that could be used as a denial of service attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-28hh-pr2h-2w89

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-28hh-pr2h-2w89

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54619

Advisory: sqlite3-ruby has Use-After-Free When Redefining SQLite Functions with Different Arity
IDs: CVE-2026-54619, GHSA-28hh-pr2h-2w89
Record: https://patchnext.com/advisories/cve-2026-54619 (revision 3, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sqlite3 2.9.5; sqlite3-ruby 2.9.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sqlite3: affected <= 2.9.4; fixed in 2.9.5
- RubyGems sqlite3-ruby: affected <= 2.9.4; fixed in 2.9.5

## Suggested inspection (read-only)
- RubyGems sqlite3: check the installed version with your package manager.
- RubyGems sqlite3-ruby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sqlite3, sqlite3-ruby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-28hh-pr2h-2w89 (OSV record GHSA-28hh-pr2h-2w89 lists affected ranges: RubyGems sqlite3-ruby >=0 =0 <2.9.5 (fixed))
- Verified: https://github.com/advisories/GHSA-28hh-pr2h-2w89 (GitHub-reviewed advisory GHSA-28hh-pr2h-2w89 lists affected ranges: RubyGems sqlite3-ruby >=0 =0 <=2.9.4)

Commands are suggestions: review each one before running it.

Loading voting…