Skip to content

← Actionable
Medium, CVSS 4.3amended

cakephp/debug_kit: MailPreview contains unsafe reflection

CVE-2026-54614GHSA-p46m-g734-vpc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/debug_kit 5.2.4, 4.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-54614: 0.54% estimated exploitation activity in the next 30 days; percentile 45.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The MailPreview feature of debugkit is vulnerable to arbitrary constructor execution. For an application to be vulnerable the following conditions must be true: 1. debug mode must be enabled. 2. The hostname must match a 'local' domain or be in an allowlist. Patches 5.2.4 and 4.10.3 contain patches for this issue. Workarounds Ensure that debugkit is only part of your development dependencies, and that debug mode is disabled in production environments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p46m-g734-vpc4

  2. Revision 1 · created ·

    Published from osv record GHSA-p46m-g734-vpc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54614

Advisory: cakephp/debug_kit: MailPreview contains unsafe reflection
IDs: CVE-2026-54614, GHSA-p46m-g734-vpc4
Record: https://patchnext.com/advisories/cve-2026-54614 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/debug_kit 5.2.4, 4.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/debug_kit: affected < 4.10.3; >= 5.0.0, < 5.2.4; fixed in 4.10.3, 5.2.4

## Suggested inspection (read-only)
- Packagist cakephp/debug_kit: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/debug_kit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p46m-g734-vpc4 (OSV record GHSA-p46m-g734-vpc4 lists affected ranges: Packagist cakephp/debug_kit >=0 =5.0.0 <5.2.4 (fixed))
- Verified: https://github.com/advisories/GHSA-p46m-g734-vpc4 (GitHub-reviewed advisory GHSA-p46m-g734-vpc4 lists affected ranges: Packagist cakephp/debug_kit >=0 =5.0.0 <5.2.4)

Commands are suggestions: review each one before running it.

Loading voting…