SunEditor Embed Plugin has DOM XSS via External Script Element After Iframe Embed
CVE-2026-54606GHSA-w93q-cq9w-58p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (suneditor 3.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm suneditor
- Affected
- >= 3.0.0, < 3.1.4
- Fixed in
- 3.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=0 <=3.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=3.0.0 <=3.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=3.0.0 <3.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-54606: 0.58% estimated exploitation activity in the next 30 days; percentile 47.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A DOM-based Cross-Site Scripting (XSS) vulnerability exists in the SunEditor Embed plugin. Crafted iframe embed HTML followed by an external element bypasses the plugin’s sanitization logic. The plugin recreates and appends the attacker-controlled script element to the live DOM, causing JavaScript execution in the context of the editor page. If an application stores or reflects SunEditor content without additional backend sanitization, this can lead to stored or reflected XSS when another user opens, previews, renders, or edits the malicious content. Details The Embed plugin parses raw embed HTML and processes the resulting DOM nodes. When a element is included after a valid iframe, the plugin creates a new script element using the attacker-controlled src value and appends it to the DOM. Relevant behavior: const embedDOM = new DOMParser().parseFromString(src, 'text/html').body.children; if (/^script$/i.test(chd.nodeName)) { scriptTag = dom.utils.createElement('script', { src:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-w93q-cq9w-58p7
- Revision 2 · amended ·
Amended from ghsa record GHSA-w93q-cq9w-58p7
- Revision 1 · created ·
Published from ghsa record GHSA-w93q-cq9w-58p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54606 Advisory: SunEditor Embed Plugin has DOM XSS via External Script Element After Iframe Embed IDs: CVE-2026-54606, GHSA-w93q-cq9w-58p7 Record: https://patchnext.com/advisories/cve-2026-54606 (revision 3, source checked 31 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: suneditor 3.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm suneditor: affected >= 3.0.0, < 3.1.4; fixed in 3.1.4 ## Suggested inspection (read-only) - `npm ls suneditor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on suneditor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w93q-cq9w-58p7 (GitHub-reviewed advisory GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=0 <=3.1.3) - Verified: https://github.com/advisories/GHSA-w93q-cq9w-58p7 (GitHub-reviewed advisory GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=3.0.0 <=3.1.3) - Verified: https://osv.dev/vulnerability/GHSA-w93q-cq9w-58p7 (OSV record GHSA-w93q-cq9w-58p7 lists affected ranges: npm suneditor >=3.0.0 <3.1.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…