Skip to content

← Actionable
High, CVSS 7.2amended

OAuth: Cross-origin token-request redirects can expose signed request metadata

CVE-2026-54605GHSA-prq8-7wvh-44qh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauth 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems oauth

    Affected
    >= 0.5.5, <= 1.1.5
    Fixed in
    1.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-54605: 0.19% estimated exploitation activity in the next 30 days; percentile 8.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-origin OAuth token-request redirects can expose signed request metadata Summary When an application uses OAuth::Consumer to request OAuth 1.0 request tokens or access tokens, the token request helper follows 300..399 redirects returned by the OAuth server. In affected versions, OAuth::Consumer#tokenrequest parses the raw Location header, follows the redirect recursively, and can mutate the consumer's configured site when the redirect points to a different host with the same path. The result is a cross-origin signed-request disclosure primitive: if an OAuth server token endpoint returns a redirect whose target an attacker controls, the client can re-sign the token request and send OAuth 1.0 request metadata, including the OAuth signature, nonce, timestamp, consumer key, and any request parameters included in the signature base string, to the attacker-controlled host. The same behavior can also be used as an SSRF or confused-deputy primitive because the application server follows…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-prq8-7wvh-44qh

  2. Revision 1 · created ·

    Published from osv record GHSA-prq8-7wvh-44qh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54605

Advisory: OAuth: Cross-origin token-request redirects can expose signed request metadata
IDs: CVE-2026-54605, GHSA-prq8-7wvh-44qh
Record: https://patchnext.com/advisories/cve-2026-54605 (revision 2, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauth 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems oauth: affected >= 0.5.5, <= 1.1.5; fixed in 1.1.6

## Suggested inspection (read-only)
- RubyGems oauth: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-prq8-7wvh-44qh (OSV record GHSA-prq8-7wvh-44qh lists affected ranges: RubyGems oauth >=0.5.5 <1.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-prq8-7wvh-44qh (GitHub-reviewed advisory GHSA-prq8-7wvh-44qh lists affected ranges: RubyGems oauth >=0.5.5 <=1.1.5)

Commands are suggestions: review each one before running it.

Loading voting…