Skip to content

← Actionable
Medium, CVSS 6.9amended

PocketSphinx: Buffer overflows in language and acoustic model loading code

CVE-2026-54559GHSA-56r5-2p2f-7cxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketsphinx 5.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54559: 0.55% estimated exploitation activity in the next 30 days; percentile 45.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The trie language model code introduced in PocketSphinx 5prealpha failed to check various boundary conditions when reading the headers of ARPA, DMP, and binary format language model files. In the case of invalid, corrupted or malicious input files, this could lead to stack and heap buffer overflows. In addition, the acoustic model loading code (which is over 30 years old...) contains numerous instances of sscanf with an unbounded string field which could also lead to stack overflows in the case of corrupt or malicious inputs. Because PocketSphinx will search the directory given by the POCKETSPHINXPATH environment variable for acoustic and language model files, if this directory is writable by untrusted users, an attacker could corrupt an existing file or write a malicious one to this directory in order to trigger the vulnerability. Patches The problem has been corrected in PocketSphinx 5.1.1. There is no patch currently available for users of Pocketsphinx 5prealpha, who are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-56r5-2p2f-7cxp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-56r5-2p2f-7cxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54559

Advisory: PocketSphinx: Buffer overflows in language and acoustic model loading code
IDs: CVE-2026-54559, GHSA-56r5-2p2f-7cxp
Record: https://patchnext.com/advisories/cve-2026-54559 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pocketsphinx 5.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pocketsphinx: affected < 5.1.1; fixed in 5.1.1

## Suggested inspection (read-only)
- `python -m pip show pocketsphinx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pocketsphinx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-56r5-2p2f-7cxp (OSV record GHSA-56r5-2p2f-7cxp lists affected ranges: PyPI pocketsphinx >=0 <5.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-56r5-2p2f-7cxp (GitHub-reviewed advisory GHSA-56r5-2p2f-7cxp lists affected ranges: PyPI pocketsphinx >=0 <5.1.1)

Commands are suggestions: review each one before running it.

Loading voting…