Skip to content

← Actionable
High, CVSS 8.2amended

http4s has HTTP/2 Denial of Service with Ember Backend

CVE-2026-54556GHSA-vmm3-xgcx-67hm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4s:http4s-ember-core_2.12 0.23.35; org.http4s:http4s-ember-core_3 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-core_2.13 1.0.0-M47, 0.23.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54556: 0.52% estimated exploitation activity in the next 30 days; percentile 44.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary http4s 0.23.x and 1.0 servers running ember with http2 enabled are vulnerable to a denial of service attack using a HPACK bomb vulnerability recently disclosed as affecting other http2 servers.

Impact Denial of Service: - Affects any http4s server running the ember backend with HTTP/2 enabled that is exposed to untrusted traffic. - Affects any http4s client running the ember backend with HTTP/2 enabled that can be directed to an untrusted server.

Details The issue occurs in the Hpack wrapper. Ember concatenates the header and continuation frames before decoding all headers at once. When the code decodes the attack payload, the relatively small packets decode to a significantly larger amount of data which is returned as a single List which is then held in memory for further processing. With enough concurrent…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-vmm3-xgcx-67hm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54556

Advisory: http4s has HTTP/2 Denial of Service with Ember Backend
IDs: CVE-2026-54556, GHSA-vmm3-xgcx-67hm
Record: https://patchnext.com/advisories/cve-2026-54556 (revision 2, source checked 25 Oct 2026, 04:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.http4s:http4s-ember-core_2.12 0.23.35; org.http4s:http4s-ember-core_3 1.0.0-M47, 0.23.35; org.http4s:http4s-ember-core_2.13 1.0.0-M47, 0.23.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.http4s:http4s-ember-core_2.12: affected < 0.23.35; fixed in 0.23.35
- Maven org.http4s:http4s-ember-core_3: affected < 0.23.35; >= 1.0.0-M1, < 1.0.0-M47; fixed in 0.23.35, 1.0.0-M47
- Maven org.http4s:http4s-ember-core_2.13: affected >= 1.0.0-M1, < 1.0.0-M47; < 0.23.35; fixed in 1.0.0-M47, 0.23.35

## Suggested inspection (read-only)
- Maven org.http4s:http4s-ember-core_2.12: check the installed version with your package manager.
- Maven org.http4s:http4s-ember-core_3: check the installed version with your package manager.
- Maven org.http4s:http4s-ember-core_2.13: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.http4s:http4s-ember-core_2.12, org.http4s:http4s-ember-core_3, org.http4s:http4s-ember-core_2.13.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vmm3-xgcx-67hm (OSV record GHSA-vmm3-xgcx-67hm lists affected ranges: Maven org.http4s:http4s-ember-core_2.12 >=0 =1.0.0-M1 =0 =0 =1.0.0-M1 <1.0.0-M47 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…