sh _uid does not drop supplementary groups (incomplete privilege drop)
CVE-2026-54552GHSA-q38v-wp89-2w55
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sh 2.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sh
- Affected
- < 2.2.4
- Fixed in
- 2.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q38v-wp89-2w55 lists affected ranges: PyPI sh >=0 <2.2.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q38v-wp89-2w55 lists affected ranges: PyPI sh >=0 <2.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.9 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-54552: 0.17% estimated exploitation activity in the next 30 days; percentile 6.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The uid option performed an incomplete privilege drop on Linux/Unix-like systems. When sh was run from a process with elevated privileges, such as root, and a command was launched with uid=<unprivileged user, the child process changed its UID and primary GID but did not reset its supplementary groups. As a result, the child process could retain the parent process’s supplementary groups, potentially including privileged groups such as root, docker, disk, shadow, or sudo. This could allow a subprocess that was expected to run with reduced privileges to access files or resources available to the original process’s supplementary groups. Users are impacted if they rely on uid as a privilege boundary when launching commands from a privileged parent process. Patches Upgrade to version = 2.2.4 Workarounds Avoid using uid when the user represents a less-privileged user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q38v-wp89-2w55
- Revision 1 · created ·
Published from osv record GHSA-q38v-wp89-2w55
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54552 Advisory: sh _uid does not drop supplementary groups (incomplete privilege drop) IDs: CVE-2026-54552, GHSA-q38v-wp89-2w55 Record: https://patchnext.com/advisories/cve-2026-54552 (revision 2, source checked 26 Oct 2026, 13:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sh 2.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sh: affected < 2.2.4; fixed in 2.2.4 ## Suggested inspection (read-only) - `python -m pip show sh`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q38v-wp89-2w55 (OSV record GHSA-q38v-wp89-2w55 lists affected ranges: PyPI sh >=0 <2.2.4 (fixed)) - Verified: https://github.com/advisories/GHSA-q38v-wp89-2w55 (GitHub-reviewed advisory GHSA-q38v-wp89-2w55 lists affected ranges: PyPI sh >=0 <2.2.4) Commands are suggestions: review each one before running it.
Loading voting…