Skip to content

← Actionable
Medium, CVSS 5.0amended

TAK-PS-Stats Web UI: Authenticated full-read SSRF in CloudTAK basemap import (PUT /api/basemap) — no IP-classification guard

CVE-2026-54546GHSA-vqrw-qphh-p34v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tak-ps/cloudtak 13.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-54546: 0.37% estimated exploitation activity in the next 30 days; percentile 31.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PUT /api/basemap (the basemap import endpoint) fetches an attacker-supplied URL server-side with no SSRF protection whatsoever. Any authenticated user can submit a JSON body { "type": "...", "url": "<attacker url" }; the server calls fetch(url) against that URL and then reflects the response body (name, attribution, tiles[0], zoom levels) back to the caller in the OptionalTileJSON response. Because there is no IP-address classification, internal-only services are reachable: cloud metadata (http://169.254.169.254/...), loopback (http://127.0.0.1/...), RFC1918 ranges, and CGNAT. The response body flows back to the attacker, making this a full-read SSRF (not blind): the attacker reads the internal HTTP response verbatim. This enables theft of cloud instance credentials, internal service enumeration, and reading of internal-only HTTP endpoints from the network position of the CloudTAK API server. The only URL check in the basemap protocol layer (BasemapProtocol.isValidURL,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vqrw-qphh-p34v

  2. Revision 1 · created ·

    Published from osv record GHSA-vqrw-qphh-p34v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54546

Advisory: TAK-PS-Stats Web UI: Authenticated full-read SSRF in CloudTAK basemap import (PUT /api/basemap) — no IP-classification guard
IDs: CVE-2026-54546, GHSA-vqrw-qphh-p34v
Record: https://patchnext.com/advisories/cve-2026-54546 (revision 2, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tak-ps/cloudtak 13.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @tak-ps/cloudtak: affected < 13.22.1; fixed in 13.22.1

## Suggested inspection (read-only)
- `npm ls @tak-ps/cloudtak --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tak-ps/cloudtak.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vqrw-qphh-p34v (OSV record GHSA-vqrw-qphh-p34v lists affected ranges: npm @tak-ps/cloudtak >=0 <13.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vqrw-qphh-p34v (GitHub-reviewed advisory GHSA-vqrw-qphh-p34v lists affected ranges: npm @tak-ps/cloudtak >=0 <13.22.1)

Commands are suggestions: review each one before running it.

Loading voting…