Skip to content

← Actionable
High, CVSS 7.1

@wakaru/cli arbitrary file write during bundle unpack

CVE-2026-54545GHSA-7wpj-vvmv-pgm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@wakaru/cli 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-54545: 0.20% estimated exploitation activity in the next 30 days; percentile 9.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact @wakaru/cli is vulnerable to arbitrary file write when unpacking a crafted JavaScript bundle with --unpack. Bundle-controlled module filenames were sanitized before writing extracted modules to the output directory. A crafted filename containing overlapping path traversal characters, such as ....//, could be transformed into ../ after sanitization. This allowed the final output path to escape the intended output directory. An attacker who can cause a user to run wakaru --unpack on a malicious bundle may be able to write files outside the selected output directory. Depending on the target path and user environment, this may lead to code execution. Affected versions: =1.0.0 <1.4.0. Patches The issue has been patched in @wakaru/cli@1.4.0. Users should upgrade to: or specifically: Workarounds Do not run wakaru --unpack on untrusted or unknown bundles with affected versions. If upgrading immediately is not possible, avoid using --unpack on files that may be attacker-controlled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7wpj-vvmv-pgm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54545

Advisory: @wakaru/cli arbitrary file write during bundle unpack
IDs: CVE-2026-54545, GHSA-7wpj-vvmv-pgm8
Record: https://patchnext.com/advisories/cve-2026-54545 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @wakaru/cli 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @wakaru/cli: affected >= 1.0.0, < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls @wakaru/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @wakaru/cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7wpj-vvmv-pgm8 (GitHub-reviewed advisory GHSA-7wpj-vvmv-pgm8 lists affected ranges: npm @wakaru/cli >=1.0.0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…