Pheditor has an authenticated terminal command whitelist bypass
CVE-2026-54540GHSA-9643-6xjp-vx57
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pheditor/pheditor 2.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pheditor/pheditor
- Affected
- <= 2.0.4
- Fixed in
- 2.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9643-6xjp-vx57 lists affected ranges: Packagist pheditor/pheditor >=0 <=2.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54540: 0.73% estimated exploitation activity in the next 30 days; percentile 54.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Pheditor 2.0.4 has an authenticated terminal command whitelist bypass. The terminal feature checks whether the submitted command starts with one of the configured TERMINALCOMMANDS values, then passes the full command string to shellexec(). Shell command substitution such as $() is not blocked, so an authenticated user with the terminal permission can bypass a restricted command allowlist and execute arbitrary shell commands as the web server user. Details Tested repository: https://github.com/pheditor/pheditor Tested commit: 62b43df7cb8956a9b0deb9bec278ca8676c890c5 Affected version: Pheditor 2.0.4 Relevant code in pheditor.php: - The terminal handler receives $POST['command'] and stores it in $command. - It blocks only &, ;, and ||. - It checks whether $command starts with one of the configured values in TERMINALCOMMANDS. - It then passes the full command string to shellexec(). Relevant logic: Because the whitelist check is prefix-based and the full command is executed by a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9643-6xjp-vx57
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54540 Advisory: Pheditor has an authenticated terminal command whitelist bypass IDs: CVE-2026-54540, GHSA-9643-6xjp-vx57 Record: https://patchnext.com/advisories/cve-2026-54540 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pheditor/pheditor 2.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pheditor/pheditor: affected <= 2.0.4; fixed in 2.0.5 ## Suggested inspection (read-only) - Packagist pheditor/pheditor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pheditor/pheditor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9643-6xjp-vx57 (GitHub-reviewed advisory GHSA-9643-6xjp-vx57 lists affected ranges: Packagist pheditor/pheditor >=0 <=2.0.4) Commands are suggestions: review each one before running it.
Loading voting…