Skip to content

← Actionable
High, CVSS 8.6amended

jupyterlab-git extension: Stored XSS leading to RCE

CVE-2026-54527GHSA-f962-v9hr-pfg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab-git 0.54.0; jupyterlab-git-core 0.54.0; @jupyterlab/git 0.54.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54527: 0.53% estimated exploitation activity in the next 30 days; percentile 44.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Amazon Web Services (AWS) Security has identified a stored cross-site scripting (XSS) issue in the jupyterlab-git JupyterLab extension that can lead to remote code execution (RCE). The issue exists in the PlainTextDiff.ts component, where the createHeader() method passes Git filenames directly to innerHTML without sanitization when rendering diffs for renamed files in commit history. This allows an adversary to craft a filename containing arbitrary HTML/JavaScript that executes when another user views the rename diff in the Git History tab. The issue can be leveraged through the rename history view in the JupyterLab Git panel. An adversary creates a file with a crafted filename containing a JavaScript payload (e.g., .py), renames the file in a subsequent commit, and pushes to a shared repository. When a victim clones the repository, navigates to the Git History tab, clicks the rename commit, and then clicks the renamed file to view the diff, the unsanitized filename renders…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 1 · created ·

    Published from osv record GHSA-f962-v9hr-pfg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54527

Advisory: jupyterlab-git extension: Stored XSS leading to RCE
IDs: CVE-2026-54527, GHSA-f962-v9hr-pfg5
Record: https://patchnext.com/advisories/cve-2026-54527 (revision 2, source checked 24 Oct 2026, 22:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab-git 0.54.0; jupyterlab-git-core 0.54.0; @jupyterlab/git 0.54.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab-git: affected >= 0.30.0b3, < 0.54.0; fixed in 0.54.0
- PyPI jupyterlab-git-core: affected >= 0.30.0b3, < 0.54.0; fixed in 0.54.0
- npm @jupyterlab/git: affected >= 0.30.0-beta.3, < 0.54.0; fixed in 0.54.0

## Suggested inspection (read-only)
- `python -m pip show jupyterlab-git`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show jupyterlab-git-core`: prints the installed version. Run with the environment that serves production active.
- `npm ls @jupyterlab/git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab-git, jupyterlab-git-core, @jupyterlab/git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f962-v9hr-pfg5 (OSV record GHSA-f962-v9hr-pfg5 lists affected ranges: PyPI jupyterlab-git >=0.30.0b3 =0.30.0b3 =0.30.0-beta.3 <0.54.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…