jackson-databind has an array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray)
CVE-2026-54513GHSA-rmj7-2vxq-3g9f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tools.jackson.core:jackson-databind 3.1.4; com.fasterxml.jackson.core:jackson-databind 3.1.4, 2.21.4, 2.18.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven tools.jackson.core:jackson-databind
- Affected
- >= 3.0.0, < 3.1.4
- Fixed in
- 3.1.4
Maven com.fasterxml.jackson.core:jackson-databind
- Affected
- >= 2.10.0, < 2.18.8>= 2.19.0, < 2.21.4>= 3.0.0, < 3.1.4
- Fixed in
- 2.21.4, 2.18.8, 3.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmj7-2vxq-3g9f lists affected ranges: Maven com.fasterxml.jackson.core:jackson-databind >=2.10.0 =2.19.0 =3.0.0 =3.0.0 <3.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54513: 1.23% estimated exploitation activity in the next 30 days; percentile 68.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary BasicPolymorphicTypeValidator.Builder.allowIfSubTypeIsArray() allowlists any array type based only on clazz.isArray(), without validating the array's component (element) type against the configured allowlist. A PTV built with allowIfSubTypeIsArray() plus an explicit concrete-type allowlist therefore still permits EvilType[] even though EvilType is not allowlisted. When Jackson deserializes the elements and no per-element type IDs are present, it instantiates the component type directly with no further PTV check, bypassing the allowlist. Impact Applications using BasicPolymorphicTypeValidator with allowIfSubTypeIsArray() as a safeguard get no protection for concrete array component types; an attacker controlling JSON can instantiate non-allowlisted types via an array wrapper, re-opening the gadget-instantiation risk PTV is meant to prevent. Affected / Patched (verified via git tag --contains) - 2.18 line: = 2.10.0, < 2.18.8 - fixed in 2.18.8 - 2.19-2.21 line: = 2.19.0, <…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rmj7-2vxq-3g9f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54513 Advisory: jackson-databind has an array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray) IDs: CVE-2026-54513, GHSA-rmj7-2vxq-3g9f Record: https://patchnext.com/advisories/cve-2026-54513 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tools.jackson.core:jackson-databind 3.1.4; com.fasterxml.jackson.core:jackson-databind 3.1.4, 2.21.4, 2.18.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven tools.jackson.core:jackson-databind: affected >= 3.0.0, < 3.1.4; fixed in 3.1.4 - Maven com.fasterxml.jackson.core:jackson-databind: affected >= 2.10.0, < 2.18.8; >= 2.19.0, < 2.21.4; >= 3.0.0, < 3.1.4; fixed in 2.21.4, 2.18.8, 3.1.4 ## Suggested inspection (read-only) - Maven tools.jackson.core:jackson-databind: check the installed version with your package manager. - Maven com.fasterxml.jackson.core:jackson-databind: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tools.jackson.core:jackson-databind, com.fasterxml.jackson.core:jackson-databind. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rmj7-2vxq-3g9f (GitHub-reviewed advisory GHSA-rmj7-2vxq-3g9f lists affected ranges: Maven com.fasterxml.jackson.core:jackson-databind >=2.10.0 =2.19.0 =3.0.0 =3.0.0 <3.1.4) Commands are suggestions: review each one before running it.
Loading voting…