Skip to content

← Actionable
Medium, CVSS 5.3

Oj: intern.c form_attr (uninitialized stack read)

CVE-2026-54500GHSA-fm7p-mprw-wjm9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oj 3.17.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems oj

    Affected
    < 3.17.3
    Fixed in
    3.17.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-54500: 0.20% estimated exploitation activity in the next 30 days; percentile 9.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Oj.load in :object mode reads uninitialized stack memory (and, for long keys, reads out of bounds) when parsing a JSON object whose key is 254 bytes or longer. The interned bytes can surface to the caller, disclosing process stack memory. Details In ext/oj/intern.c, formattr() handles the long-key path by allocating a heap buffer b, populating it with the attribute name, and then freeing it — but it passed the uninitialized stack buffer buf (not b) to rbintern3(): rbintern3 therefore reads len + 1 bytes of uninitialized stack memory. When the key length is = 256, it also reads out of bounds past the 256-byte buf (CWE-125). The resulting bytes are interned and can reach the caller via the produced Symbol or via the EncodingError message raised on invalid UTF-8, leaking process stack contents. This is the same defect previously fixed in ext/oj/usual.c; intern.c held a duplicated copy of formattr that was missed. Proof of Concept On affected versions this raises an EncodingError…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fm7p-mprw-wjm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54500

Advisory: Oj: intern.c form_attr (uninitialized stack read)
IDs: CVE-2026-54500, GHSA-fm7p-mprw-wjm9
Record: https://patchnext.com/advisories/cve-2026-54500 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oj 3.17.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems oj: affected < 3.17.3; fixed in 3.17.3

## Suggested inspection (read-only)
- RubyGems oj: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oj.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fm7p-mprw-wjm9 (GitHub-reviewed advisory GHSA-fm7p-mprw-wjm9 lists affected ranges: RubyGems oj >=0 <3.17.3)

Commands are suggestions: review each one before running it.

Loading voting…