ViewComponent: around_render HTML-Safety Bypass
CVE-2026-54498GHSA-97jw-64cj-jc58
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (view_component 4.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems view_component
- Affected
- >= 4.0.0, < 4.12.0
- Fixed in
- 4.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-97jw-64cj-jc58 lists affected ranges: RubyGems view_component >=4.0.0 <4.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-54498: 0.45% estimated exploitation activity in the next 30 days; percentile 39.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ViewComponent::Base#aroundrender can return HTML-unsafe strings that bypass the escaping behavior applied to normal #call return values. This creates an XSS risk when downstream applications use aroundrender to wrap, replace, instrument, or conditionally return content that includes user-controlled data. The issue is especially dangerous in collection rendering because ViewComponent::Collection#renderin joins the per-item results and marks the entire output as htmlsafe, converting raw unsafe output into a trusted ActiveSupport::SafeBuffer. Affected Code Validated against: - Repository commit: eea79445 - Ruby: 3.4.9 Relevant locations: - lib/viewcomponent/base.rb - renderin - aroundrender - vcmaybeescapehtml - lib/viewcomponent/template.rb - InlineCall#safemethodnamecall - lib/viewcomponent/collection.rb - Collection#renderin Key code paths: Root Cause Normal inline #call output is passed through vcmaybeescapehtml, which escapes HTML-unsafe strings. However, when aroundrender…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-97jw-64cj-jc58
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54498 Advisory: ViewComponent: around_render HTML-Safety Bypass IDs: CVE-2026-54498, GHSA-97jw-64cj-jc58 Record: https://patchnext.com/advisories/cve-2026-54498 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: view_component 4.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems view_component: affected >= 4.0.0, < 4.12.0; fixed in 4.12.0 ## Suggested inspection (read-only) - RubyGems view_component: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on view_component. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-97jw-64cj-jc58 (GitHub-reviewed advisory GHSA-97jw-64cj-jc58 lists affected ranges: RubyGems view_component >=4.0.0 <4.12.0) Commands are suggestions: review each one before running it.
Loading voting…