websocket-driver: Resource limit bypass via message compression
CVE-2026-54490GHSA-mp7j-qc5w-4988
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (websocket-driver 0.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm websocket-driver
- Affected
- < 0.7.5
- Fixed in
- 0.7.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp7j-qc5w-4988 lists affected ranges: npm websocket-driver >=0 <0.7.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp7j-qc5w-4988 lists affected ranges: npm websocket-driver >=0 <0.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2026-54490: 0.45% estimated exploitation activity in the next 30 days; percentile 38.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If this library is used in tandem with the permessage-deflate extension, a WebSocket server or client can be made to accept messages that are larger than the configured maximum message size. This is because this limit is checked against the message frames' length headers, which give the size of the compressed data, not the size after decompression. This can lead to applications accepting larger messages than expected and exceeding their intended resource usage. Patches The issue has been patched in version 0.7.5, by checking the length of messages after they are processed by incoming extensions. All users should upgrade to this version. Workarounds No known workarounds exist. Acknowledgements This issue was discovered and reported by Pranjali Thakur, DepthFirst Security Research Team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mp7j-qc5w-4988
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mp7j-qc5w-4988
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54490 Advisory: websocket-driver: Resource limit bypass via message compression IDs: CVE-2026-54490, GHSA-mp7j-qc5w-4988 Record: https://patchnext.com/advisories/cve-2026-54490 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: websocket-driver 0.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm websocket-driver: affected < 0.7.5; fixed in 0.7.5 ## Suggested inspection (read-only) - `npm ls websocket-driver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on websocket-driver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mp7j-qc5w-4988 (OSV record GHSA-mp7j-qc5w-4988 lists affected ranges: npm websocket-driver >=0 <0.7.5 (fixed)) - Verified: https://github.com/advisories/GHSA-mp7j-qc5w-4988 (GitHub-reviewed advisory GHSA-mp7j-qc5w-4988 lists affected ranges: npm websocket-driver >=0 <0.7.5) Commands are suggestions: review each one before running it.
Loading voting…