Skip to content

← Actionable
High, CVSS 7.7amended

TensorZero Gateway: Arbitrary file read and SSRF in internal object storage endpoint

CVE-2026-54457GHSA-824w-x939-6cmc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorzero 2026.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-54457: 0.40% estimated exploitation activity in the next 30 days; percentile 34.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The /internal/objectstorage endpoint accepts a caller-supplied JSON storagepath parameter that dynamically overrides the TensorZero [objectstorage] configuration. By abusing the filesystem storage type, a caller can read arbitrary files from the gateway filesystem, including files that may contain sensitive credentials. Similarly, by abusing the s3compatible storage type, the caller can coerce the gateway into making outbound object storage requests to attacker-chosen internal/cloud-metadata endpoints. This vulnerability only applies when the gateway can be accessed by untrusted callers. If a developer's TensorZero deployment has authentication enabled, only authenticated callers can exploit this vulnerability. If a developer's deployment has authentication disabled, any caller can exploit this vulnerability. Remediation The vulnerability has been patched in version 2026.6.0. See PR #7527. Workarounds If developers are unable to upgrade a gateway that is exposed to untrusted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-824w-x939-6cmc

  2. Revision 1 · created ·

    Published from osv record GHSA-824w-x939-6cmc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54457

Advisory: TensorZero Gateway: Arbitrary file read and SSRF in internal object storage endpoint
IDs: CVE-2026-54457, GHSA-824w-x939-6cmc
Record: https://patchnext.com/advisories/cve-2026-54457 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorzero 2026.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorzero: affected < 2026.6.0; fixed in 2026.6.0

## Suggested inspection (read-only)
- `python -m pip show tensorzero`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorzero.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-824w-x939-6cmc (OSV record GHSA-824w-x939-6cmc lists affected ranges: PyPI tensorzero >=0 <2026.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-824w-x939-6cmc (GitHub-reviewed advisory GHSA-824w-x939-6cmc lists affected ranges: PyPI tensorzero >=0 <2026.6.0)

Commands are suggestions: review each one before running it.

Loading voting…