Skip to content

← Actionable
Medium, CVSS 4.8amended

NationalSecurityAgency/emissary has an incomplete fix for CVE-2026-35571

CVE-2026-54442GHSA-c6q7-wqw2-h65w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gov.nsa.emissary:emissary 8.51.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The URL validation regex `^(https?:/)?/.*` added to emissary's `NavAction.java` allows protocol-relative URLs (`//evil.com/...`) and single-slash scheme variants (`http:/evil.com`) to bypass validation, enabling SSRF and open redirect attacks.

Affected Package - Ecosystem: Maven - Package: NationalSecurityAgency/emissary - Affected versions: = e2078417464b

Severity Medium

CWE CWE-918 — Server-Side Request Forgery (SSRF)

Details The fix in `NavAction.java` (line 47) introduces a `VALID_LINK` pattern: ```java Pattern.compile("^(https?:/)?/.*") ``` This regex is intended to restrict navigation links to relative paths and HTTP/HTTPS URLs. However, it has multiple bypass vectors. Protocol-relative URLs (`//evil.com/...`): The group `(https?:/)?` is optional, so the pattern reduces to `//.*` when the group is absent. This matches `//evil.com/steal?c=SESSION`, which browsers resolve to the current page's protocol plus the attacker's host. Single-slash…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-c6q7-wqw2-h65w

  2. Revision 1 · created ·

    Published from ghsa record GHSA-c6q7-wqw2-h65w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54442

Advisory: NationalSecurityAgency/emissary has an incomplete fix for CVE-2026-35571
IDs: CVE-2026-54442, GHSA-c6q7-wqw2-h65w
Record: https://patchnext.com/advisories/cve-2026-54442 (revision 2, source checked 31 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gov.nsa.emissary:emissary 8.51.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven gov.nsa.emissary:emissary: affected < 8.51.0; fixed in 8.51.0

## Suggested inspection (read-only)
- Maven gov.nsa.emissary:emissary: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gov.nsa.emissary:emissary.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c6q7-wqw2-h65w (GitHub-reviewed advisory GHSA-c6q7-wqw2-h65w lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <8.51.0)
- Verified: https://osv.dev/vulnerability/GHSA-c6q7-wqw2-h65w (OSV record GHSA-c6q7-wqw2-h65w lists affected ranges: Maven gov.nsa.emissary:emissary >=0 <8.51.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…