Skip to content

← Actionable
High, CVSS 7.5

Apache HttpComponents Core: HPackDecoder Unlimited Header List Size Before SETTINGS ACK

CVE-2026-54428GHSA-v3jc-474w-2wm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.httpcomponents.core5:httpcore5-h2 5.5-beta2, 5.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-54428: 0.87% estimated exploitation activity in the next 30 days; percentile 58.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Allocation of resources without limits or throttling in the HTTP/2 HPACK decoder in Apache HttpComponents Core (5.4.2 and earlier, 5.5-beta1 and earlier) allows an remote attacker to cause a denial of service through memory exhaustion by sending oversized compressed header blocks before the HTTP/2 SETTINGS acknowledgement causes the configured header list size limit to be applied.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v3jc-474w-2wm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54428

Advisory: Apache HttpComponents Core: HPackDecoder Unlimited Header List Size Before SETTINGS ACK
IDs: CVE-2026-54428, GHSA-v3jc-474w-2wm6
Record: https://patchnext.com/advisories/cve-2026-54428 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.httpcomponents.core5:httpcore5-h2 5.5-beta2, 5.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.httpcomponents.core5:httpcore5-h2: affected < 5.4.3; >= 5.5-alpha1, < 5.5-beta2; fixed in 5.4.3, 5.5-beta2

## Suggested inspection (read-only)
- Maven org.apache.httpcomponents.core5:httpcore5-h2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.httpcomponents.core5:httpcore5-h2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v3jc-474w-2wm6 (GitHub-reviewed advisory GHSA-v3jc-474w-2wm6 lists affected ranges: Maven org.apache.httpcomponents.core5:httpcore5-h2 >=0 =5.5-alpha1 <5.5-beta2)

Commands are suggestions: review each one before running it.

Loading voting…