Skip to content

← Actionable
Critical, CVSS 10.0amended

Budibase has nonymous NoSQL operator injection via published-app query templates

CVE-2026-54350GHSA-8qv3-p479-cj62

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-54350: 0.54% estimated exploitation activity in the next 30 days; percentile 45.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary enrichContext at packages/server/src/sdk/workspace/queries/queries.ts:121-138 substitutes parameter values into the raw JSON body of a query, then JSON.parses the result. The validator validateQueryInputs at packages/server/src/api/controllers/query/index.ts:61-71 rejects only Handlebars markers ({{, }}) in user input and does not escape JSON metacharacters (", \, }). A parameter value containing a closing quote and additional keys lifts attacker-controlled fields into the parsed filter object. For Mongo find, the parsed filter passes directly to collection.find() (packages/server/src/integrations/mongodb.ts:506-510). Duplicate-key JSON parsing overrides the builder's {name: "..."} with {name: {$exists: true}} and returns every document. The same primitive against an updateMany query (mongodb.ts:577-585) widens the filter scope to the full collection while the builder-controlled $set body runs against every matched document. The authorized middleware at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8qv3-p479-cj62

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8qv3-p479-cj62

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8qv3-p479-cj62

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54350

Advisory: Budibase has nonymous NoSQL operator injection via published-app query templates
IDs: CVE-2026-54350, GHSA-8qv3-p479-cj62
Record: https://patchnext.com/advisories/cve-2026-54350 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.12; fixed in 3.39.12

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qv3-p479-cj62 (GitHub-reviewed advisory GHSA-8qv3-p479-cj62 lists affected ranges: npm @budibase/server >=0 <3.39.12)
- Verified: https://osv.dev/vulnerability/GHSA-8qv3-p479-cj62 (OSV record GHSA-8qv3-p479-cj62 lists affected ranges: npm @budibase/server >=0 <3.39.12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…