Skip to content

← Actionable
High, CVSS 7.2amended

Froxlor: Second-Order SQL Injection via Admins.add ipaddress Parameter Allows Full Database Exfiltration

CVE-2026-54348GHSA-w27m-rmmf-g5w4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-54348: 0.66% estimated exploitation activity in the next 30 days; percentile 51.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A second-order SQL injection vulnerability in Froxlor's admin API allows an authenticated administrator to store a crafted SQL payload in the paneladmins.ip column via the Admins.add or Admins.update endpoint. The payload executes as a UNION-based SQL injection the next time IpsAndPorts.listing is called by the poisoned account, returning arbitrary data from the database — including all administrator login names and bcrypt password hashes. --- Details The vulnerability spans two code locations that form a store-then-trigger chain. Stage 1 — Unsanitized array stored as JSON — lib/Froxlor/Api/Commands/Admins.php:251,358 The INSERT/UPDATE uses a prepared statement, so the write itself is safe. The danger is what is stored. Stage 2 — JSON payload imploded directly into SQL — lib/Froxlor/Api/Commands/IpsAndPorts.php:71-77 The same unsanitized implode pattern exists in lib/Froxlor/Api/Commands/Domains.php:1016. Every other place in the codebase that builds dynamic IN clauses uses…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w27m-rmmf-g5w4

  2. Revision 1 · created ·

    Published from osv record GHSA-w27m-rmmf-g5w4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54348

Advisory: Froxlor: Second-Order SQL Injection via `Admins.add` `ipaddress` Parameter Allows Full Database Exfiltration
IDs: CVE-2026-54348, GHSA-w27m-rmmf-g5w4
Record: https://patchnext.com/advisories/cve-2026-54348 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist froxlor/froxlor: affected < 2.3.8; fixed in 2.3.8

## Suggested inspection (read-only)
- Packagist froxlor/froxlor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on froxlor/froxlor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w27m-rmmf-g5w4 (OSV record GHSA-w27m-rmmf-g5w4 lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-w27m-rmmf-g5w4 (GitHub-reviewed advisory GHSA-w27m-rmmf-g5w4 lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.8)

Commands are suggestions: review each one before running it.

Loading voting…