Skip to content

← Actionable
High, CVSS 8.7amended

Froxlor: Stored XSS in DNS TXT Record Content Allows Customer-to-Admin Account Takeover

CVE-2026-54347GHSA-43gm-9rr3-cx7g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-54347: 0.42% estimated exploitation activity in the next 30 days; percentile 35.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored Cross-Site Scripting (XSS) vulnerability in Froxlor's DNS editor allows an authenticated user with DNS editor access (customer role) to inject arbitrary JavaScript into any administrator's browser session. When an administrator views the DNS configuration of an affected domain, the payload executes automatically — enabling complete admin account takeover, credential theft, and full server compromise. --- Details Three code locations combine to create this vulnerability: 1. Input validation does not strip HTML special characters — lib/Froxlor/Api/Commands/DomainZones.php:158 2. Display callback returns raw HTML without escaping — lib/Froxlor/UI/Callbacks/Text.php:95 3. Twig template renders the callback output with |raw — templates/Froxlor/table/table.html.twig:57 The DNS editor table assigns [Text::class, 'wordwrap'] as the callback for the content column (lib/tablelisting/tablelisting.dns.php:58). The callback returns a non-iterable string, so the template falls to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-43gm-9rr3-cx7g

  2. Revision 1 · created ·

    Published from osv record GHSA-43gm-9rr3-cx7g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54347

Advisory: Froxlor: Stored XSS in DNS TXT Record Content Allows Customer-to-Admin Account Takeover
IDs: CVE-2026-54347, GHSA-43gm-9rr3-cx7g
Record: https://patchnext.com/advisories/cve-2026-54347 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist froxlor/froxlor: affected <= 2.3.7; fixed in 2.3.8

## Suggested inspection (read-only)
- Packagist froxlor/froxlor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on froxlor/froxlor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-43gm-9rr3-cx7g (OSV record GHSA-43gm-9rr3-cx7g lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-43gm-9rr3-cx7g (GitHub-reviewed advisory GHSA-43gm-9rr3-cx7g lists affected ranges: Packagist froxlor/froxlor >=0 <=2.3.7)

Commands are suggestions: review each one before running it.

Loading voting…