Pi Agent: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts
CVE-2026-54328GHSA-jfgx-wxx8-mp94
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @mariozechner/pi-coding-agent
- Affected
- >= 0.50.0, <= 0.73.1
- Fixed in
- no fixed version recorded
npm @earendil-works/pi-coding-agent
- Affected
- >= 0.74.0, < 0.78.1
- Fixed in
- 0.78.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfgx-wxx8-mp94 lists affected ranges: npm @earendil-works/pi-coding-agent >=0.74.0 =0.50.0 <=0.73.1
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfgx-wxx8-mp94 lists affected ranges: npm @earendil-works/pi-coding-agent >=0.74.0 =0.50.0 <=0.73.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-54328: 0.16% estimated exploitation activity in the next 30 days; percentile 5.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. Info The vulnerable code path affected temporary extension package sources loaded with --extension or -e, specifically npm and git package sources. The temporary npm install root and temporary git clone paths were deterministic and rooted under os.tmpdir()/pi-extensions. The path was derived from public source information rather than from a per-user private directory or an unpredictable temporary directory. During resource resolution, pi considered an npm…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfgx-wxx8-mp94
- Revision 1 · created ·
Published from osv record GHSA-jfgx-wxx8-mp94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54328 Advisory: Pi Agent: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts IDs: CVE-2026-54328, GHSA-jfgx-wxx8-mp94 Record: https://patchnext.com/advisories/cve-2026-54328 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @earendil-works/pi-coding-agent 0.78.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @mariozechner/pi-coding-agent: affected >= 0.50.0, <= 0.73.1 - npm @earendil-works/pi-coding-agent: affected >= 0.74.0, < 0.78.1; fixed in 0.78.1 ## Suggested inspection (read-only) - `npm ls @mariozechner/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @earendil-works/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @mariozechner/pi-coding-agent, @earendil-works/pi-coding-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfgx-wxx8-mp94 (OSV record GHSA-jfgx-wxx8-mp94 lists affected ranges: npm @earendil-works/pi-coding-agent >=0.74.0 =0.50.0 <=0.73.1) - Verified: https://github.com/advisories/GHSA-jfgx-wxx8-mp94 (GitHub-reviewed advisory GHSA-jfgx-wxx8-mp94 lists affected ranges: npm @earendil-works/pi-coding-agent >=0.74.0 =0.50.0 <=0.73.1) Commands are suggestions: review each one before running it.
Loading voting…