Skip to content

← Actionable
Low, CVSS 2.2amended

Pi Agent: Race condition in Pi auth.json writes could expose stored credentials

CVE-2026-54327GHSA-r95r-rj6r-c39x

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @mariozechner/pi-coding-agent

    Affected
    >= 0.28.0, <= 0.73.1
    Fixed in
    no fixed version recorded
  • npm @earendil-works/pi-coding-agent

    Affected
    >= 0.74.0, < 0.78.1
    Fixed in
    0.78.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.2 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-54327: 0.09% estimated exploitation activity in the next 30 days; percentile 0.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Pi auth.json writes could briefly expose stored credentials to local users Pi stored API keys and OAuth credentials in auth.json. A race condition in the file write path could briefly create or rewrite this file with permissions derived from the process umask before tightening the file to owner-only permissions. Info The affected credential storage code wrote auth.json and then corrected the file mode in a separate operation. During the interval between those operations, a local user who could read and traverse the Pi agent configuration directory could potentially read the file before its permissions were restricted. The file can contain API keys, OAuth access tokens, and OAuth refresh tokens for configured providers. The affected behavior was present in the original auth.json credential storage implementation and thus affects both the original @mariozechner/pi-coding-agent package as well as @earendil-works/pi-coding-agent. Impact Exploitation requires local access to the same…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r95r-rj6r-c39x

  2. Revision 1 · created ·

    Published from osv record GHSA-r95r-rj6r-c39x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54327

Advisory: Pi Agent: Race condition in Pi auth.json writes could expose stored credentials
IDs: CVE-2026-54327, GHSA-r95r-rj6r-c39x
Record: https://patchnext.com/advisories/cve-2026-54327 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @earendil-works/pi-coding-agent 0.78.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @mariozechner/pi-coding-agent: affected >= 0.28.0, <= 0.73.1
- npm @earendil-works/pi-coding-agent: affected >= 0.74.0, < 0.78.1; fixed in 0.78.1

## Suggested inspection (read-only)
- `npm ls @mariozechner/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @earendil-works/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @mariozechner/pi-coding-agent, @earendil-works/pi-coding-agent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r95r-rj6r-c39x (OSV record GHSA-r95r-rj6r-c39x lists affected ranges: npm @mariozechner/pi-coding-agent >=0.28.0 =0.74.0 <0.78.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r95r-rj6r-c39x (GitHub-reviewed advisory GHSA-r95r-rj6r-c39x lists affected ranges: npm @mariozechner/pi-coding-agent >=0.28.0 =0.74.0 <0.78.1)

Commands are suggestions: review each one before running it.

Loading voting…