Pi Agent: Potential XSS in HTML session exports via Markdown URL sanitization bypass
CVE-2026-54326GHSA-7v5m-pr3q-6453
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @mariozechner/pi-coding-agent
- Affected
- >= 0.27.5, <= 0.73.1
- Fixed in
- no fixed version recorded
npm @earendil-works/pi-coding-agent
- Affected
- >= 0.74.0, < 0.78.1
- Fixed in
- 0.78.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7v5m-pr3q-6453 lists affected ranges: npm @mariozechner/pi-coding-agent >=0.27.5 =0.74.0 <0.78.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7v5m-pr3q-6453 lists affected ranges: npm @mariozechner/pi-coding-agent >=0.27.5 =0.74.0 <0.78.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-54326: 0.17% estimated exploitation activity in the next 30 days; percentile 6.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Potential XSS in HTML session exports via Markdown URL handling Pi HTML exports render session Markdown into a static HTML file. Affected versions did not consistently reject unsafe Markdown link and image URL schemes. In versions with scheme filtering, C0 control characters in the URL scheme could bypass the check because browsers normalize those characters before navigation. Impact The realistic attack path is indirect. An attacker would need to get suitable Markdown into a session, for example through prompt injection that causes the model to include an unsafe link, or through other untrusted session content. The user would then need to export the session as HTML, open or share that file, and click the link. If triggered, script runs in the exported document, not in pi or the user's shell. The main risk is limited disclosure of data embedded in that exported session file. Affected versions - Affected: @mariozechner/pi-coding-agent = 0.27.5, <= 0.73.1 - Affected:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7v5m-pr3q-6453
- Revision 1 · created ·
Published from osv record GHSA-7v5m-pr3q-6453
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54326 Advisory: Pi Agent: Potential XSS in HTML session exports via Markdown URL sanitization bypass IDs: CVE-2026-54326, GHSA-7v5m-pr3q-6453 Record: https://patchnext.com/advisories/cve-2026-54326 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @earendil-works/pi-coding-agent 0.78.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @mariozechner/pi-coding-agent: affected >= 0.27.5, <= 0.73.1 - npm @earendil-works/pi-coding-agent: affected >= 0.74.0, < 0.78.1; fixed in 0.78.1 ## Suggested inspection (read-only) - `npm ls @mariozechner/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @earendil-works/pi-coding-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @mariozechner/pi-coding-agent, @earendil-works/pi-coding-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7v5m-pr3q-6453 (OSV record GHSA-7v5m-pr3q-6453 lists affected ranges: npm @mariozechner/pi-coding-agent >=0.27.5 =0.74.0 <0.78.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7v5m-pr3q-6453 (GitHub-reviewed advisory GHSA-7v5m-pr3q-6453 lists affected ranges: npm @mariozechner/pi-coding-agent >=0.27.5 =0.74.0 <0.78.1) Commands are suggestions: review each one before running it.
Loading voting…