Skip to content

← Actionable
Medium, CVSS 6.3amended

n8n: Denial of Service via ZIP decompression in webhook workflow

CVE-2026-54314GHSA-jqpw-qww5-cj4c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.24.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 2.24.0
    Fixed in
    2.24.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54314: 0.55% estimated exploitation activity in the next 30 days; percentile 45.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Compression node's Decompress operation expanded attacker-controlled archives into memory without enforcing limits on decompressed output size. An unauthenticated attacker could send a small compressed archive to a public webhook workflow using this node, causing the n8n process to terminate due to memory exhaustion and disrupting all workflows in the same instance. Patches The issue has been fixed in n8n version 2.24.0. Users should upgrade to this version or later to remediate the vulnerability. The fix introduces configurable limits on decompressed output size (N8NCOMPRESSIONNODEMAXDECOMPRESSEDSIZEBYTES) and ZIP entry count (N8NCOMPRESSIONNODEMAXZIPENTRIES). Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Disable the Compression node by adding n8n-nodes-base.compression to the NODESEXCLUDE environment variable. - Restrict public webhook workflows that accept archive file uploads to authenticated…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jqpw-qww5-cj4c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jqpw-qww5-cj4c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54314

Advisory: n8n: Denial of Service via ZIP decompression in webhook workflow
IDs: CVE-2026-54314, GHSA-jqpw-qww5-cj4c
Record: https://patchnext.com/advisories/cve-2026-54314 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.24.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 2.24.0; fixed in 2.24.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jqpw-qww5-cj4c (OSV record GHSA-jqpw-qww5-cj4c lists affected ranges: npm n8n >=0 <2.24.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jqpw-qww5-cj4c (GitHub-reviewed advisory GHSA-jqpw-qww5-cj4c lists affected ranges: npm n8n >=0 <2.24.0)

Commands are suggestions: review each one before running it.

Loading voting…