n8n: NoSQL Injection in MongoDB Node Find And Replace Operation
CVE-2026-54313GHSA-jpq7-226w-6cxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 2.24.0
- Fixed in
- 2.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jpq7-226w-6cxx lists affected ranges: npm n8n >=0 <2.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpq7-226w-6cxx lists affected ranges: npm n8n >=0 <2.24.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-54313: 0.34% estimated exploitation activity in the next 30 days; percentile 27.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with workflow edit access could supply a malicious filter value in the MongoDB node's Find And Replace operation. The value was not validated before being passed to MongoDB as a query filter, allowing unintended documents to be matched and overwritten with attacker-controlled content. Patches The issue has been fixed in n8n version 2.24.0. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the MongoDB node by adding n8n-nodes-base.mongoDb to the NODESEXCLUDE environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jpq7-226w-6cxx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jpq7-226w-6cxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54313 Advisory: n8n: NoSQL Injection in MongoDB Node Find And Replace Operation IDs: CVE-2026-54313, GHSA-jpq7-226w-6cxx Record: https://patchnext.com/advisories/cve-2026-54313 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 2.24.0; fixed in 2.24.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jpq7-226w-6cxx (OSV record GHSA-jpq7-226w-6cxx lists affected ranges: npm n8n >=0 <2.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jpq7-226w-6cxx (GitHub-reviewed advisory GHSA-jpq7-226w-6cxx lists affected ranges: npm n8n >=0 <2.24.0) Commands are suggestions: review each one before running it.
Loading voting…