n8n: Credential Exfiltration via Permission Bypass
CVE-2026-54307GHSA-pmqw-72cg-wx85
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.26.2, 2.25.7, 1.123.55), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.55>= 2.26.0, < 2.26.2>= 2.0.0-rc.0, < 2.25.7
- Fixed in
- 2.25.7, 2.26.2, 1.123.55
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pmqw-72cg-wx85 lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pmqw-72cg-wx85 lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:L · score source
- EPSS
- CVE-2026-54307: 0.39% estimated exploitation activity in the next 30 days; percentile 32.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow sharing to fully trusted users only. - Audit shared workflows for unexpected credential references or recent modifications. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures. --- n8n has adopted CVSS 4.0 as primary score for all security…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pmqw-72cg-wx85
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pmqw-72cg-wx85
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-54307 Advisory: n8n: Credential Exfiltration via Permission Bypass IDs: CVE-2026-54307, GHSA-pmqw-72cg-wx85 Record: https://patchnext.com/advisories/cve-2026-54307 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.26.2, 2.25.7, 1.123.55. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.55; >= 2.26.0, < 2.26.2; >= 2.0.0-rc.0, < 2.25.7; fixed in 2.25.7, 2.26.2, 1.123.55 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pmqw-72cg-wx85 (OSV record GHSA-pmqw-72cg-wx85 lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7 (fixed)) - Verified: https://github.com/advisories/GHSA-pmqw-72cg-wx85 (GitHub-reviewed advisory GHSA-pmqw-72cg-wx85 lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7) Commands are suggestions: review each one before running it.
Loading voting…