Skip to content

← Actionable
High, CVSS 8.9amended

n8n: Cross-Tenant Credential Takeover via Dynamic Credentials EE Endpoints

CVE-2026-54305GHSA-2j5h-858j-5mpf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.26.2, 2.25.7, 1.123.55), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.55>= 2.26.0, < 2.26.2>= 2.0.0-rc.0, < 2.25.7
    Fixed in
    2.25.7, 2.26.2, 1.123.55

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L · score source
EPSS
  • CVE-2026-54305: 0.37% estimated exploitation activity in the next 30 days; percentile 31.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Three EE endpoints used by the Dynamic Credentials feature accepted any authenticated n8n session without performing per-resource ownership or scope checks on the target workflow or credential. An authenticated user with no project membership or credential sharing relationship could enumerate credential identifiers, names, and types referenced by any private workflow in the instance, initiate an OAuth authorization flow against another user's credential to overwrite its stored tokens with tokens bound to an account they control, or revoke another user's stored credential tokens entirely. Workflows relying on a hijacked credential would subsequently execute under the attacker's OAuth identity, enabling data exfiltration to attacker-controlled external services and persistent takeover of integrations. Token revocation would break affected workflows. This issue only affects Enterprise instances where the Dynamic Credentials feature is enabled. Patches The issue has been fixed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2j5h-858j-5mpf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2j5h-858j-5mpf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54305

Advisory: n8n: Cross-Tenant Credential Takeover via Dynamic Credentials EE Endpoints
IDs: CVE-2026-54305, GHSA-2j5h-858j-5mpf
Record: https://patchnext.com/advisories/cve-2026-54305 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.26.2, 2.25.7, 1.123.55. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.55; >= 2.26.0, < 2.26.2; >= 2.0.0-rc.0, < 2.25.7; fixed in 2.25.7, 2.26.2, 1.123.55

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2j5h-858j-5mpf (OSV record GHSA-2j5h-858j-5mpf lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7 (fixed))
- Verified: https://github.com/advisories/GHSA-2j5h-858j-5mpf (GitHub-reviewed advisory GHSA-2j5h-858j-5mpf lists affected ranges: npm n8n >=0 =2.26.0 =2.0.0-rc.0 <2.25.7)

Commands are suggestions: review each one before running it.

Loading voting…