Skip to content

← Actionable
High, CVSS 8.2

PostgreSQL JDBC Driver: Silent channel-binding authentication downgrade via unsupported certificate algorithms

CVE-2026-54291GHSA-j92g-9f8w-j867

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.postgresql:postgresql 42.7.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-54291: 0.24% estimated exploitation activity in the next 30 days; percentile 14.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact channelBinding=require connections can be silently downgraded from SCRAM-SHA-256-PLUS (with channel binding) to plain SCRAM-SHA-256 (without it), losing the man-in-the-middle protection the setting is meant to guarantee. An attacker who can intercept the TLS connection triggers the downgrade with a certificate whose signature algorithm has no tls-server-end-point channel-binding hash. Examples are Ed25519, Ed448, and post-quantum algorithms. Two issues combine in releases 42.7.4 through 42.7.11: 1. The bundled com.ongres.scram:scram-client (3.1 or 3.2) returns an empty byte array instead of failing when it cannot derive the binding hash for such a certificate. This is the library issue tracked as GHSA-p9jg-fcr6-3mhf. 2. pgJDBC does not enforce channelBinding=require where it matters. ScramAuthenticator checks only that the server advertised a -PLUS mechanism; it neither rejects the empty binding nor checks that the negotiated mechanism uses channel binding. The connection…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j92g-9f8w-j867

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54291

Advisory: PostgreSQL JDBC Driver: Silent channel-binding authentication downgrade via unsupported certificate algorithms
IDs: CVE-2026-54291, GHSA-j92g-9f8w-j867
Record: https://patchnext.com/advisories/cve-2026-54291 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.postgresql:postgresql 42.7.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.postgresql:postgresql: affected >= 42.7.4, < 42.7.12; fixed in 42.7.12

## Suggested inspection (read-only)
- Maven org.postgresql:postgresql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.postgresql:postgresql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j92g-9f8w-j867 (GitHub-reviewed advisory GHSA-j92g-9f8w-j867 lists affected ranges: Maven org.postgresql:postgresql >=42.7.4 <42.7.12)

Commands are suggestions: review each one before running it.

Loading voting…